CodeIgniter Forums
default controller - Printable Version

+- CodeIgniter Forums (https://forum.codeigniter.com)
+-- Forum: Archived Discussions (https://forum.codeigniter.com/forum-20.html)
+--- Forum: Archived Development & Programming (https://forum.codeigniter.com/forum-23.html)
+--- Thread: default controller (/thread-3183.html)



default controller - El Forum - 09-14-2007

[eluser]Unknown[/eluser]
We're getting ready to launch our site, however we've recently come across an issue where it seems as if the default controller doesn't always load or it is not always found. When the happens we end of with a 404 error.

Has anyone else experienced this same issue? Has anyone been able to resolve this?


default controller - El Forum - 09-14-2007

[eluser]Michael Wales[/eluser]
1. Is this a consistent issue or just happens sparingly?
2. Turn on logging on your application - next time it happens checkout the logs.
3. Can you access the default controller reliably by manually visiting it (http://www.mydomain.com/index.php/controller) rather than letting it load as the default from just the domain being requested?


default controller - El Forum - 09-17-2007

[eluser]Unknown[/eluser]
I appologize for the delay in my response.

>1. Is this a consistent issue or just happens sparingly?

This happens sparingly.

> 2. Turn on logging on your application - next time it happens checkout the logs.

I will check the logs the next time this happens, but I reacall the logs not being very useful the last time I check this issue. It just displays the standard '404' not found.

> 3. Can you access the default controller reliably by manually visiting it
> (http://www.mydomain.com/index.php/controller) rather than letting it load as the default > from just the domain being requested?

I can reliably access the controller manually. We are using apache rewrite rules for cleaner urls. I'm wondering if that will cause any known issues.

Just a little background, on our server:

Apache 1.3.31
PHP 5.0.1
CodeIgniter 1.5.3