CodeIgniter Forums
Installation Issues - Printable Version

+- CodeIgniter Forums (https://forum.codeigniter.com)
+-- Forum: Archived Discussions (https://forum.codeigniter.com/forum-20.html)
+--- Forum: Archived General Discussion (https://forum.codeigniter.com/forum-21.html)
+--- Thread: Installation Issues (/thread-32839.html)



Installation Issues - El Forum - 08-06-2010

[eluser]D_Williams[/eluser]
I just downloaded CI figuring I'd give it a spin and see if I like it. I followed the installation instructions (and viewed several other installation tutorials to make sure I wasn't misunderstanding) but it doesn't work for me. I don't get an error or anything, just a blank page.

I'm testing this on Ubuntu 10.04. My web folder is /var/www. I made a /var/www/citest folder and extracted the codeigniter zip into that folder. I went to config.php and changed base_url to "http://localhost/citest" since this is just my local machine that doesn't have a domain name. I tried changing it to my local IP and a couple other things but every time I just get a blank page instead of loading the default controller, or "directory access not allowed" if I try to access any folders deeper than citest.

What am I doing wrong? It seems like a very simple installation but it's just not working for some reason. I have verified that PHP and Apache are indeed working correctly by placing a phpinfo() file in /var/www. It displays as expected.


Installation Issues - El Forum - 08-06-2010

[eluser]WanWizard[/eluser]
If you get 'directory access not allowed', maybe your apache config doesn't see index.php as a valid index file.
If you type http://localhost/citest/index.php, does it work?

A blank page is usually caused by a syntax error in the code, with error_reporting and/or display_errors switched off in php.ini, so you should check that as well.
On a development machine, it's wise to enable all error reporting you can find, to make sure no errors remain undetected.


Installation Issues - El Forum - 08-06-2010

[eluser]D_Williams[/eluser]
[quote author="WanWizard" date="1281136543"]If you get 'directory access not allowed', maybe your apache config doesn't see index.php as a valid index file.
If you type http://localhost/citest/index.php, does it work?

A blank page is usually caused by a syntax error in the code, with error_reporting and/or display_errors switched off in php.ini, so you should check that as well.
On a development machine, it's wise to enable all error reporting you can find, to make sure no errors remain undetected.[/quote]

Aha that got me rolling. Turns out it wasn't an issue with CI.

Apparently since the last LTS release of Ubuntu, display_errors has changed from a default of on to being off (actually the php.ini comments say it's on by default but it was off and I just installed php in this machine and never touched the config file). My production machine is running 8.04 (haven't upgraded yet), and I specifically remember having to turn error reporting off so I just assumed it was still going to default to on with my 10.04 machine.

Turning errors on revealed that it was a permission problem with my CI files, so I got that corrected and it works fine now.

Thanks for the help!