CodeIgniter Forums
CodeIgniter on PHP 5+ only? - Printable Version

+- CodeIgniter Forums (https://forum.codeigniter.com)
+-- Forum: Archived Discussions (https://forum.codeigniter.com/forum-20.html)
+--- Forum: Archived General Discussion (https://forum.codeigniter.com/forum-21.html)
+--- Thread: CodeIgniter on PHP 5+ only? (/thread-33568.html)



CodeIgniter on PHP 5+ only? - El Forum - 08-31-2010

[eluser]whizzer[/eluser]
Hello,
me and my colleagues are in the process of rewriting a large website with 1M+ unique visitors a month. We're making an update because the website is growing very fast and we need more people to write code and a framework is the perfect solution. We've had some small projects with CI before. However in this case we're seeking speed so we decided to use a really fast framework. I know this is a plus but with its compatibility with PHP 4.3+ CI is a bit slowed down. So I'm wondering if there will ever be a PHP 5+ only version, using the full potential of the object-orientated model in PHP?
Thank you.


CodeIgniter on PHP 5+ only? - El Forum - 08-31-2010

[eluser]pickupman[/eluser]
Use CI2-dev. php4 has been deprecated, and most of Ellis Labs projects are already on it. You can grab it from bitbucket.org You may also find it more solid than 1.7.2 as most bug fixes have been rolled into 2.0 and forward.