CodeIgniter Forums
HTML5 - Printable Version

+- CodeIgniter Forums (https://forum.codeigniter.com)
+-- Forum: Archived Discussions (https://forum.codeigniter.com/forum-20.html)
+--- Forum: Archived General Discussion (https://forum.codeigniter.com/forum-21.html)
+--- Thread: HTML5 (/thread-34955.html)



HTML5 - El Forum - 10-14-2010

[eluser]Raul Predescu[/eluser]
Hey guys.
I bought a template and i want to build an application based on codeigniter.
Now, the template has multiple html5 tags, like header and footer and nav.
CI 1.7.2 does not know all those tags. I tried with load->view, parser->parse and output->show_output and none works.

I tried same things with CI 2.0 and it works, template it's displaying like it should.
Can somebody help me implement that in CI 1.7.2 ?

Thanks in advance.

Raul


HTML5 - El Forum - 10-14-2010

[eluser]cahva[/eluser]
CI has nothing to do with different versions of HTML so you must have done something wrong. You said "none works". What do you mean? Does the header, footer and nav tags magically dissapear when you output the sourcecode from the browser? Smile Most probably you have done something wrong and it did not load CSS correctly or something.. Use also firebug (or developer tools on chrome) to see that it actually loads everything and does not have any 404 errors on js, css and other files.


HTML5 - El Forum - 10-14-2010

[eluser]Raul Predescu[/eluser]
Well, i didn't do anything wrong, i just saw the output wrong in any browser.
And yes, i double check with developer tools. One thing that i saw it's that the <header> tag was closed before it should be.
Same for footer. Nav tags looks to work fine.

Creepy anyway.


HTML5 - El Forum - 10-14-2010

[eluser]InsiteFX[/eluser]
You should not be using HTML 5 in an application even the W3C says that!

If you want to play around with it fine. But do not put it on the web.

InsiteFX


HTML5 - El Forum - 10-14-2010

[eluser]Raul Predescu[/eluser]
It has nothing to do with that. The pure html source with html5 works fine until i'm loading it into codeigniter.
Also, ci2.0 works fine, but , it's beta.
So the only thing i'm asking is HOW 2.0 parse html5 tags and if that can be done in 1.7.2

Thanks,

Raul


HTML5 - El Forum - 10-15-2010

[eluser]Twisted1919[/eluser]
I'm in with cahva, codeigniter has nothing to do with the html5 thing .
Try like this, take your index.html from the template, put it in a view file and load it into a variable , something like :
Code:
$var = $this->load->view('my-full-view','',TRUE);
exit($var);

Be sure that the images/css/js points to the right direction and they are loaded, then see if the output matches what you expect.

Anyway, i'm more than sure that you do something wrong, not codeigniter.

P.S: Daca esti roman, dupa cum se pare, da-mi un p.m cu id-ul de mess in caz ca nu gasesti rezolvarea si poate te pot ajuta mai mult acolo.


HTML5 - El Forum - 10-15-2010

[eluser]Raul Predescu[/eluser]
Hey guys.

Yes, i was wrong. Something in template called html5.js was the trick. Everything works fine with it.

Thanks again,

Raul