CodeIgniter Forums
failed move of codeigniter[Solved] - Printable Version

+- CodeIgniter Forums (https://forum.codeigniter.com)
+-- Forum: Archived Discussions (https://forum.codeigniter.com/forum-20.html)
+--- Forum: Archived Development & Programming (https://forum.codeigniter.com/forum-23.html)
+--- Thread: failed move of codeigniter[Solved] (/thread-36127.html)



failed move of codeigniter[Solved] - El Forum - 11-22-2010

[eluser]mwarehime[/eluser]
Recently the entire website has been moved from one host to another. So I am told the system folder previously existed above the htdocs folder. Since the move the syetem folder had to be reloaded insode of htdocs because the host does not allow access above htdocs. This move broke the website. There is too much invested to not get this working. I suspect that the configutation in .htaccess is wrong. Code Igniter does not seem to take off. the default route is set to welcome and welcome_message.php is referenced in the controller properly. welcome_message.php is custom. The application just hangs and timesout. Any ideas where this went wrong?


failed move of codeigniter[Solved] - El Forum - 11-22-2010

[eluser]smilie[/eluser]
Did you change index.php in your application folder to target new location of application folder?

Cheers,
Smilie


failed move of codeigniter[Solved] - El Forum - 11-22-2010

[eluser]mwarehime[/eluser]
the index.php file has been changed and with a hack i checked in index.php the the system full path that becomes BASEPATH and APPPATH seems to me to be pointing properly. I commented out the start of the require once directive to CodeIgniter and allowed an echo statement of the path it is getting for BASEPATH is right.


failed move of codeigniter[Solved] - El Forum - 11-22-2010

[eluser]BigDon[/eluser]
Your supposition about the .htaccess file being the culprit may be on target. I have had similar issues with the .htaccess file not permitting me to launch files on my local development machine.

You could try temporarily moving the .htaccess file out of the root of the web site and see if you can access the site. If so, then a modification to the file would be necessary. If the site still will not load, I would check that the permissions on the site are correct and that the host provider is pointing to the correct folder.


failed move of codeigniter[Solved] - El Forum - 11-22-2010

[eluser]mwarehime[/eluser]
moving the .htaccess file out had no effect. The settings from the host should be allright. THe problem is everything looks like it should. There is a .htacess file in some of the sub folders. I am not expert in mod rewite. I tried this without thinking all that should happen is an ugly URL but did not make any difference in the outcome. I am working on this on my development machine and I get no response either.


failed move of codeigniter[Solved] - El Forum - 11-23-2010

[eluser]mwarehime[/eluser]
I checked the access log file And I see this entry when i try to pull up the website.

23/Nov/2010:10:58:14 -0500] "GET / HTTP/1.1" 302 - "-" "Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 6.1; Trident/4.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; InfoPath.2; .NET4.0C)"
76.21.166.170 - - [23/Nov/2010:11:01:26 -0500] "GET / HTTP/1.1" 302 - "-" "Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 6.1; Trident/4.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; InfoPath.2; .NET4.0C)"

Shouldn't there be something just after the GET that looks like a path? What would cause this?


failed move of codeigniter[Solved] - El Forum - 11-23-2010

[eluser]n0xie[/eluser]
You probably need to change the uri_protocol in config.php. It might be that you also need to change your .htaccess.


failed move of codeigniter[Solved] - El Forum - 11-23-2010

[eluser]mwarehime[/eluser]
I moved out the .htacess file from the root and changed config.php to QUERY_STRING and this is what i see now. But it just won't kickoff codeigniter

[23/Nov/2010:11:45:41 -0500] "GET /index.php HTTP/1.1" 302 - "-" "Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 6.1; Trident/4.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; InfoPath.2; .NET4.0C)"


failed move of codeigniter[Solved] - El Forum - 11-23-2010

[eluser]mwarehime[/eluser]
This is the .htaccess file contents:

<Files "error_log">
Order allow,deny
deny from all
</Files>

RewriteEngine on
RewriteCond $1 !^(.+\.php|img|images|robots\.txt|.+\.css|.+\.js|.+\.swf|.+\.flv|.+\.xls|.+\.pdf|.+\.png|.+\.html)
RewriteRule ^(.*)$ /index.php?/$1 [L]