CodeIgniter Forums
User login redirect problem in IE - Printable Version

+- CodeIgniter Forums (https://forum.codeigniter.com)
+-- Forum: Archived Discussions (https://forum.codeigniter.com/forum-20.html)
+--- Forum: Archived Development & Programming (https://forum.codeigniter.com/forum-23.html)
+--- Thread: User login redirect problem in IE (/thread-36988.html)



User login redirect problem in IE - El Forum - 12-22-2010

[eluser]Unknown[/eluser]
I have a simple login where the user submits their login credentials, everything is checked, and if their credentials are correct they are redirected to the members section. If the criteria fails the login screen is reloaded with an error message. I am using a simple redirect() in codeigniter which works fine in all my browsers except IE (what a shocker). I read it's a caching problem and they said to add this line
html4strict Code:
Code:
<head>
<meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
<meta http-equiv="pragma" content="no-cache" />
<meta http-equiv="Expires" content="-1" />
<meta http-equiv="CACHE-CONTROL" content="NO-CACHE" />

</head>

Which is what i did. For some reason the page just keeps refreshing every time i try to login. The really weird thing is when I use IE 8 on a windows machine it refreshes the page, but running parallels on my mac with the same windows 7 IE 8 setup, i DONT get the refresh problem. I used to have the problem on my parallels setup until i read that i should change ci_sessions to cisessions and that fixed it. But i still have the problem with multiple PC's running IE. Does anyone have the slightest clue as to what could be going on here?


User login redirect problem in IE - El Forum - 12-22-2010

[eluser]mi6crazyheart[/eluser]
Can't say a lot about it. But, may be that 3rd line(<meta http-equiv="Expires" content="-1" /&gtWink is causing problem. Just omit that 3rd line & execute u'r page.


User login redirect problem in IE - El Forum - 12-23-2010

[eluser]markup2go[/eluser]
Haven't had the same issue... but paste some code and maybe someone can help you further. Start with your core config file and the function being called.


User login redirect problem in IE - El Forum - 12-23-2010

[eluser]InsiteFX[/eluser]
Check under your IE options tab and make sure you are
allowing all cookies!

InsiteFX