CodeIgniter Forums
colorbox and codeigniter question - Printable Version

+- CodeIgniter Forums (https://forum.codeigniter.com)
+-- Forum: Archived Discussions (https://forum.codeigniter.com/forum-20.html)
+--- Forum: Archived Development & Programming (https://forum.codeigniter.com/forum-23.html)
+--- Thread: colorbox and codeigniter question (/thread-40204.html)



colorbox and codeigniter question - El Forum - 04-01-2011

[eluser]miramichi[/eluser]
I am trying to get colorbox to diplay a .swf file. If I host the file off site, it works. I want to host it on site, but I get an error by linking to the swf, or by linking to a page that has the .swf embedded in it. I created controllers & pages for stuff to appear in a content area, but I dont want the whole page to show up in the colorbox, just the swf. but I am at a loss for the moment. I hope this makes sense.

Link: http//www.miramichi.ca
(click to play video)


colorbox and codeigniter question - El Forum - 04-02-2011

[eluser]Basketcasesoftware[/eluser]
What on earth is "colorbox"? What is the error message?


colorbox and codeigniter question - El Forum - 04-02-2011

[eluser]Basketcasesoftware[/eluser]
And your link appears broken.


colorbox and codeigniter question - El Forum - 04-02-2011

[eluser]Madmartigan1[/eluser]
This is definitely a bug with Codeigniter Reactor.
Alert the mods! Smile


colorbox and codeigniter question - El Forum - 04-02-2011

[eluser]Basketcasesoftware[/eluser]
ok. The link works.For some reason my browser was wanting to render it http://http://.... First I've ever seen that happen. Anyways, the site seems to be working as far as I can tell. And the acting in Movie#1! Stupendous! ;-P Seriously, you need to have the correct troubling videos actually in place for us to look.


colorbox and codeigniter question - El Forum - 04-07-2011

[eluser]miramichi[/eluser]
Thanks for delving into this. Here is some code and maybe a better explanation:

I can't get my flash movies to play in CI. All the Flash files are in a folder at the root level. The embed/object code below works fine when I upload it to another site (non-CI).

To see this in action got to miramichi dot ca (I don't have permission to post links here), and click on the video links. The image link goes off site and works. The text link tries to open the view below, and fails.

If you think the solution is .htaccess, please post an example. Thanks!



Controller code:
Code:
class Video extends Controller
{
    function Video()
    {
        parent::Controller();
    }
    
    function index()
    {
        $this->load->view('video');
    }
}

View Code:
Code:
[removed][removed]
</head>
<body>
<object id="FlashID" classid="clsid:D27CDB6E-AE6D-11cf-96B8-444553540000" width="720" height="600">
  <param name="movie" value="http://www.miramichi.ca/Flash/ssp.swf">
  <param name="quality" value="high">
  <param name="wmode" value="opaque">
  <param name="swfversion" value="6.0.65.0">
  &lt;!-- This param tag prompts users with Flash Player 6.0 r65 and higher to download the latest version of Flash Player. Delete it if you don’t want users to see the prompt. --&gt;
  <param name="expressinstall" value="http://www.miramichi.ca/Scripts/expressInstall.swf">
  &lt;!-- Next object tag is for non-IE browsers. So hide it from IE using IECC. --&gt;
  &lt;!--[if !IE]>--&gt;
  &lt;object type="application/x-shockwave-flash" data="http://www.miramichi.ca/Flash/ssp.swf" width="720" height="600"&gt;
    &lt;!--<![endif]--&gt;
    <param name="quality" value="high">
    <param name="wmode" value="opaque">
    <param name="swfversion" value="6.0.65.0">
    <param name="expressinstall" value="http://www.miramichi.ca/Scripts/expressInstall.swf">
    &lt;!-- The browser displays the following alternative content for users with Flash Player 6.0 and older. --&gt;
    <div>
      <h4>Content on this page requires a newer version of Adobe Flash Player.</h4>
      <p><a href="http://www.adobe.com/go/getflashplayer"><img src="http://www.adobe.com/images/shared/download_buttons/get_flash_player.gif" alt="Get Adobe Flash player" width="112" height="33" /></a></p>
    </div>
    &lt;!--[if !IE]>--&gt;
  &lt;/object&gt;
  &lt;!--<![endif]--&gt;
&lt;/object&gt;
[removed]
&lt;!--
swfobject.registerObject("FlashID");
//--&gt;
[removed]
&lt;/body&gt;



colorbox and codeigniter question - El Forum - 04-07-2011

[eluser]miramichi[/eluser]
Hi:

Problem solved by adding the folling to my .htaccess:

RewriteEngine On
RewriteCond $1 !^(index\.php|Flash)
RewriteRule ^(.*)$ index.php?/$1 [L]

Cheers,

L