CodeIgniter Forums
Setting up and using Auth (Tank Auth in particular) - Printable Version

+- CodeIgniter Forums (https://forum.codeigniter.com)
+-- Forum: Archived Discussions (https://forum.codeigniter.com/forum-20.html)
+--- Forum: Archived Development & Programming (https://forum.codeigniter.com/forum-23.html)
+--- Thread: Setting up and using Auth (Tank Auth in particular) (/thread-42424.html)



Setting up and using Auth (Tank Auth in particular) - El Forum - 06-07-2011

[eluser]rbwilkinson[/eluser]
I am posting this in an attempt to help others get Auth working quickly.
I have recently started using CodeIgniter and I am very pleased with the power and security that it has.
There have been issues as there is a learning curve.
My head is presently trying to figure out the proper manner to setup and use Tank Auth.
The documentation is light indeed. I have it working. Now what?
I need to integrate it with my application.
I have a few years experience with PHP and I know my way around web servers and the like.
After installing Tank Auth I had some issues getting it to run. Primarily my fault as my permissions on the folders had to adjusted. I don't know why that happened but it caused a lot of head scratching to begin with.
IF you are having problems out of the gate ... CHECK your permissions.
I don't have time at this moment to add much more. I will be updating my progress with Tank Auth. As I learn ... hopefully so will other noobs.

bermudgeek dot com


Setting up and using Auth (Tank Auth in particular) - El Forum - 06-08-2011

[eluser]rbwilkinson[/eluser]
A little more searching led me to this.

http://ellislab.com/forums/viewthread/158821/

I am still working on it.

One of the problems that I am experiencing is that my images arent loading from the auth/login.
When I link back to the main index my images aren't loading and the url shows as mysite.com/index.php/auth/login. Wrong look and annoying.


Setting up and using Auth (Tank Auth in particular) - El Forum - 06-09-2011

[eluser]rbwilkinson[/eluser]
I think I have it working after a lot of tinkering. CI forces you to maintain standards. Which is brilliant.
Trying to get the Cart to work now. There is not a lot of help available. Good to use brain. Lot's of time used though.
You must be sure that all relevant libraries and helpers are loaded. Take extra care when laying out the controllers and views. That tripped me up a lot.
More in depth later.


Setting up and using Auth (Tank Auth in particular) - El Forum - 08-01-2012

[eluser]sanguina[/eluser]
Hey have you figured out out to access the admin area in Tank Auth - I see Tank Auth allows admin area backend to ban users.

thanks