CodeIgniter Forums
Issue during uploading website from localhost to server - Printable Version

+- CodeIgniter Forums (https://forum.codeigniter.com)
+-- Forum: Archived Discussions (https://forum.codeigniter.com/forum-20.html)
+--- Forum: Archived Development & Programming (https://forum.codeigniter.com/forum-23.html)
+--- Thread: Issue during uploading website from localhost to server (/thread-43508.html)



Issue during uploading website from localhost to server - El Forum - 07-13-2011

[eluser]kingstone16[/eluser]
When the files are still in my localhost, there were no problem at all.
Before I uploaded it, I edited base_url in config.php
After that I uploaded using FileZIlla

When I try to access the website (www.rateschoice.com), the codeigniter function didn't work instead it showed as text html. Anybody can help me to solve this problem ?

For further information please click url below
http://www.rateschoice.com/

Note : I upload in Server Linux based

Thank you before Smile


Issue during uploading website from localhost to server - El Forum - 07-13-2011

[eluser]Jaketoolson[/eluser]
that's weird.

What version PHP are you running? Do you have short-tags disabled in your php.ini ?
Code:
short_open_tag = On



Issue during uploading website from localhost to server - El Forum - 07-13-2011

[eluser]kingstone16[/eluser]
Wow you are genius !! Big Grin
Thanks for the help


Issue during uploading website from localhost to server - El Forum - 07-13-2011

[eluser]Jaketoolson[/eluser]
Honestly, I would not use short-tags. PHP 6 will be deprecating short_tags so I'd encourage you to just not use short tags and change them:
Code:
//from
<?

//to
<?php