CodeIgniter Forums
Error 404 Page Not Found --> js - Printable Version

+- CodeIgniter Forums (https://forum.codeigniter.com)
+-- Forum: CodeIgniter Archived (from EllisLab) (https://forum.codeigniter.com/forum-20.html)
+--- Forum: Archived Development & Programming (https://forum.codeigniter.com/forum-23.html)
+--- Thread: Error 404 Page Not Found --> js (/thread-50435.html)



Error 404 Page Not Found --> js - El Forum - 03-26-2012

[eluser]skunkio[/eluser]
Hi all,
I have configured today MAMP on my laptop in order to have my site accesible even locally. I have modified my .htacces file, created my db unders MAMP and everything seems to work properly except for some js files.
Checking my site I have tried to login (login calls a js) and it's not working. Having a look into my log file I noticed the row below

Code:
404 Page Not Found --> js

Seems like that my js file is not called or the link is not recognized.
Checking on internet I have found another post with the same same so I have checked my base_url() that seems to be ok. Moreover, if I recall my js file with the same link is inside the page that calls the same js, I'm able to access on it and see its contents. I guess there are no issues with the link.
Is there something more that I can check?

Thanks in advance


Error 404 Page Not Found --> js - El Forum - 03-26-2012

[eluser]JoostV[/eluser]
You may want to check whether you are using relative urls to your js files. This is the most common thing to go wrong when using 'pretty' urls like CI does.

A good solution is to use absolute URLs using the url helper
Code:
[removed][removed]

Another solution is to set a base href tag in your page <head>.


Error 404 Page Not Found --> js - El Forum - 03-26-2012

[eluser]InsiteFX[/eluser]
Code:
// html head section
<head>
    <base href="<?php echo base_url();?>" />

// Replace $ with s in script tags!

    <$cript type="text/javascript" charset="utf-8">
        //&lt;![CDATA[
            var base_url = "&lt;?php echo base_url(); ?&gt;";
            var site_url = "&lt;?php echo site_url(); ?&gt;";
        // ]]>
    </$cript>
&lt;/head&gt;



Error 404 Page Not Found --&gt; js - El Forum - 03-27-2012

[eluser]skunkio[/eluser]
Thank you for your answers first of all.
I think I'm not getting the point so I try to explain better what I have done.

My MAMP webroot is like

Quote:MAMP
htdocs
my_site_folder
site
application_front
config
controllers
...
.
public
images
css
javascript
upload

and inside my config file I have the configuration below

Code:
$config['base_url']           = $PROTOCOL.$_SERVER['HTTP_HOST']."/";
$config['front_base_url']   = $config['base_url'];
$config['file_upload_base_url']          = $config['front_base_url']."upload/";
$config['css_images_js_base_url'] = $config['base_url']."public/";

if($_SERVER['HTTP_HOST'] == "localhost:8888" )
{
$config['base_url']    .= "my_site_folder/";  
$config['front_base_url']   = "http://".$_SERVER['HTTP_HOST']."my_site_folder/";
$config['server_absolute_path']  = "/my_site_folder/site";
$config['file_upload_absolute_path'] = "/my_site_folder/upload/";
$config['file_upload_base_url']   = $config['front_base_url']."upload/";
$config['css_images_js_base_url'] = $config['base_url']."site/public/";
}
else
{
        my live server configuration is here
}

then within my view i have, within the head this line to recall my js file

Code:
<$cript type="text/javascript" src="&lt;?php echo css_images_js_base_url();?&gt;javascript/my_js.js"></$cript>

the source of the page is correct and like below

Quote:<$cript type="text/javascript" src="http://localhost:8888/my_site_folder/site/public/javascript/my_js.js"><$cript>

For the css and images the same approach is working.
Then I have tried to add the base_url() tag within the &lt;header&gt; and change the path of my js with a relative one but without the echo part. Same result, it's not working.
What is wrong with my configuration?

Thanks in advance for your support


Error 404 Page Not Found --&gt; js - El Forum - 03-27-2012

[eluser]CodeIgniteMe[/eluser]
This may be a file permission issue.
One you could try is to install firebug(fully functional on firefox) then monitor the Net tab to see what status per file is being returned. You can also identify what could have caused the error and what contents does the js file return.


Error 404 Page Not Found --&gt; js - El Forum - 03-28-2012

[eluser]skunkio[/eluser]
I have installed firebug and it really helped me, I have found the issue in less than one minute. There was nothing wrong in my configuration. My mistake was a variable set with my real domain instead than my localhost. It's clear I have a lot to learn about web development and issues linked with this.

Thanks


Error 404 Page Not Found --&gt; js - El Forum - 03-28-2012

[eluser]CodeIgniteMe[/eluser]
Good to know. Glad you're eager to learn more.