CodeIgniter Forums
Login session not working in IE - Printable Version

+- CodeIgniter Forums (https://forum.codeigniter.com)
+-- Forum: Archived Discussions (https://forum.codeigniter.com/forum-20.html)
+--- Forum: Archived General Discussion (https://forum.codeigniter.com/forum-21.html)
+--- Thread: Login session not working in IE (/thread-56196.html)

Pages: 1 2


Login session not working in IE - El Forum - 12-03-2012

[eluser]nirmal.jingar[/eluser]
The login session is not working in IE. After login it redirected to the same page again.
I have already tried the following solution, but no luck
1. native session
2. changed sess_expiration to 0
3. added cookie domain
4. changed sess_cookie_name to cisession
5. changed sess_match_useragent to false


Login session not working in IE - El Forum - 12-03-2012

[eluser]InsiteFX[/eluser]
You may need to modify these in your IE Browser.

1) Click on the menu tools.
2) Click on Internet Options.
3) Click on the Privacy Tab.
4) Click on the Advanced button.
5) Check the checkbox - Always allow session cookies.
6) Adjust the other options to your preferences.



Login session not working in IE - El Forum - 12-03-2012

[eluser]nirmal.jingar[/eluser]
Thanks for the help
I have enabled the "Always allow session cookies", it still redirecting me to login page.


Login session not working in IE - El Forum - 12-03-2012

[eluser]nirmal.jingar[/eluser]
Can anybody help me please?


Login session not working in IE - El Forum - 12-03-2012

[eluser]InsiteFX[/eluser]
Do a print_r or var_dump of your session data to make sure it is being set.



Login session not working in IE - El Forum - 12-03-2012

[eluser]nirmal.jingar[/eluser]
I can see the session data on login screen, but when it redirected to home page the session is empty.


Login session not working in IE - El Forum - 12-03-2012

[eluser]nirmal.jingar[/eluser]
It was working few days back, I really don't have any idea why it is not working now!


Login session not working in IE - El Forum - 12-04-2012

[eluser]NikosV[/eluser]
try changing the name of the session cookie and leave it without an underscore.
example: from "ci_session" to "cisession"


Login session not working in IE - El Forum - 12-04-2012

[eluser]nirmal.jingar[/eluser]
Hi Nikos,

Please see my first post.
I have already tried the following solution, but no luck
1. used native session class
2. changed sess_expiration to 0
3. added cookie domain
4. changed sess_cookie_name to cisession
5. changed sess_match_useragent to false


Login session not working in IE - El Forum - 12-04-2012

[eluser]ThePaavero[/eluser]
Make sure you don't have underscores in a possible subdomain. IE freaks out and won't keep the session going if you do.