CodeIgniter Forums
Help with CodeIgniter setup and WAMP - Printable Version

+- CodeIgniter Forums (https://forum.codeigniter.com)
+-- Forum: Archived Discussions (https://forum.codeigniter.com/forum-20.html)
+--- Forum: Archived General Discussion (https://forum.codeigniter.com/forum-21.html)
+--- Thread: Help with CodeIgniter setup and WAMP (/thread-57428.html)



Help with CodeIgniter setup and WAMP - El Forum - 03-13-2013

[eluser]vambavan[/eluser]
I am a web development newbie. All my form submits result in 404 error (when choosing uri protocol other than PATH_INFO and ORIG_PATH_INFO. When PATH_INFO or ORIG_PATH_INFO and I do a redirect, the url changes correctly but the original default view is displayed again. Please help! I have been at it for several days and cant figure it out. Any other info you need I can add to the post. Appreciate any ideas for me to try.

I installed CodeIgniter with the application and system folders under the www directory. The application is in application/baseApplication. Here is how my config files, .htaccess and relevant portions of httpd.conf look like.

application, system and www are at the same level
.htaccess is in www


.htaccess in www looks like this:
-------------------------------
RewriteEngine On
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule ^(.*)$ index.php?$1 [L]

index.php in www
-------------------------------
$system_path = 'C:\WAMP\system';
$application_folder = 'C:\WAMP\application\baseApplication';


httpd.conf
-----------------
LoadModule rewrite_module modules/mod_rewrite.so (uncommented out)

DocumentRoot "c:/wamp/www"
<Directory "c:/wamp/www/">
AllowOverride All
Options None
Order allow,deny
Allow from all
</Directory>
<Directory "c:/wamp/application/baseApplication/">
AllowOverride All
Options None
Order allow,deny
Allow from all
</Directory>
<Directory "c:/wamp/application/baseApplication/controllers/">
AllowOverride All
Options None
Order allow,deny
Allow from all
</Directory>
<Directory "c:/wamp/application/baseApplication/models/">
AllowOverride All
Options None
Order allow,deny
Allow from all
</Directory>
<Directory "c:/wamp/application/baseApplication/views/">
AllowOverride All
Options None
Order allow,deny
Allow from all
</Directory>

I followed the instructions @ http://www.cmjackson.net/2009/06/30/how-to-setup-codeigniter/



Help with CodeIgniter setup and WAMP - El Forum - 03-13-2013

[eluser]dm_punks[/eluser]
Hi, vambavan.

There is a setting inside /application/config/config.php that looks like this:

$config['index_page'] = 'index.php';

You can try setting that to blank like this:

$config['index_page'] = '';

Hope that helps.