CodeIgniter Forums
AWS Elastic Beanstalk problem - Printable Version

+- CodeIgniter Forums (https://forum.codeigniter.com)
+-- Forum: Archived Discussions (https://forum.codeigniter.com/forum-20.html)
+--- Forum: Archived Development & Programming (https://forum.codeigniter.com/forum-23.html)
+--- Thread: AWS Elastic Beanstalk problem (/thread-60066.html)



AWS Elastic Beanstalk problem - El Forum - 01-08-2014

[eluser]Unknown[/eluser]
I have successfully deployed my application for testing in a standard EC2 instance.

But when I build an environment in Elastic Beanstalk (PHP Stack)and attempt to deploy there, codeigniter is so unhappy that I get a white screen of death, otherwise known as no output whatsoever. No stack trace, no complaint. Just gone

I have done some tracing.

1. It doesn't matter what endpoint (controller) I am trying to reach.
2. It is dying in core/CodeIgniter.php on this call:
Code:
$EXT->_call_hook('post_controller_constructor');
Execution never reaches the next line in CodeIgniter.php.
3. there are no error messages in the apache logs or the codeigniter log. Last lines in the CI log:

Code:
DEBUG - 2014-01-08 20:56:51 --> Model Class Initialized
DEBUG - 2014-01-08 20:56:51 --> Model Class Initialized
DEBUG - 2014-01-08 20:56:51 --> Config file loaded: application/config/gl_config.php

I use no hooks, to the best of my knowledge, in this app, at this time.

Currently EB uses PHP 5.5

I am puzzled by this issue. I hesitate to explore Codeigniter system code because I have not encountered any issues there before.
The app is actually in production on a cheap virtual server at the moment.
I assume there is a config issue or a release issue (php, other middleware).
Typically I have seen the white screen of death when I try to use a loadable library or other code that does not exist.

I need some advice as to where to look to see the actual failure - I suspect when I see it I will know the fix!


AWS Elastic Beanstalk problem - El Forum - 01-09-2014

[eluser]Unknown[/eluser]
(Solved)

I had a fatal error due to an incompatability in my own code with php5.5. The fatal error was being surpressed. Once I unsurpressed it, I saw it and remedied it in 2 min.

When trying to alter my original post to mark 'solved' I got:

Quote:Due to a heavy increase of spam within our community, the privilege of posting certain content is currently reserved for active community members and those who have purchased our software.

If you feel you have received this in error, please contact [email protected] with a support key of h4rv1uax-2hkcw088-oswksgsg-80ww48w for more information.