CodeIgniter Forums
Blank page on upgrade from 2.1.4 to 2.2.x - Printable Version

+- CodeIgniter Forums (https://forum.codeigniter.com)
+-- Forum: Using CodeIgniter (https://forum.codeigniter.com/forum-5.html)
+--- Forum: General Help (https://forum.codeigniter.com/forum-24.html)
+--- Thread: Blank page on upgrade from 2.1.4 to 2.2.x (/thread-61452.html)



Blank page on upgrade from 2.1.4 to 2.2.x - objecttothis - 04-16-2015

My web application is working fine on PHP 5.6.6 running CI 2.1.4. upgrading to CI 3.0.0 breaks a lot of the code so I'm wanting to upgrade to the most stable legacy version (2.2.2) however when I follow the upgrade instructions, my web app just loads a blank page with no source and no error log.

Working web app:
PHP 5.6.6
MySQL 5.5.x
CI 2.1.4
MySQLi driver

Not working
PHP 5.6.6
MySQL 5.5.x
CI 2.2.0 or 2.2.2
MySQLi driver

I've backed up the old system directory and replaced it with the new as well as the same with the index.php

Ideas?


RE: Blank page on upgrade from 2.1.4 to 2.2.x - gadelat - 04-16-2015

enable error logs to see where is problem


RE: Blank page on upgrade from 2.1.4 to 2.2.x - objecttothis - 04-17-2015

set the error logs to level 4 and that informed me that I had not set the datetime element in my php.ini file (unrelated). It also gave me: Fatal error: Call to undefined function hash_hmac() in .../system/libraries/Session.php on line 162

Turns out I needed to install php56-hash-5.6.7 in my php installation. After installing the package and restarting apache all was well. Props @gadelat for getting me to the right direction.


RE: Blank page on upgrade from 2.1.4 to 2.2.x - alkarim - 04-21-2015

Me too having the same problem with my web app....please help


RE: Blank page on upgrade from 2.1.4 to 2.2.x - objecttothis - 04-21-2015

(04-21-2015, 05:54 AM)alkarim Wrote: Me too having the same problem with my web app....please help

Did you modify php.ini and the codeignitor error log toggle to show you the error reports? If so, what errors come up? Is it the exact same problem (2.1.4 works but 2.2.2 or 2.2.0 don't)?

If you are on a hosted service provider then you may not be able to access the php.ini for the installation but you can put a php.ini in your root directory and override the error logs there.