CodeIgniter Forums
issue during upgrading 2.2.4 to 3.0 - Printable Version

+- CodeIgniter Forums (https://forum.codeigniter.com)
+-- Forum: Development (https://forum.codeigniter.com/forum-6.html)
+--- Forum: Issues (https://forum.codeigniter.com/forum-19.html)
+--- Thread: issue during upgrading 2.2.4 to 3.0 (/thread-62809.html)



issue during upgrading 2.2.4 to 3.0 - shaheb - 08-28-2015

Any help will be hight appreciated:

I upgrade CI from 2.2.4 to 3.0

and all stopped working. other all I have fixed but now this image uploading is not working.
NOTE: post data does not contain crf-token, I have disabled in config to get it done.

Please see the image for detail request/response and error


RE: issue during upgrading 2.2.4 to 3.0 - mwhitney - 08-31-2015

It looks like at least one error message is not completely displayed in that screenshot.
Are you trying to call a controller from another controller?


RE: issue during upgrading 2.2.4 to 3.0 - shaheb - 09-01-2015

Hi,
thanks for reply. no that's all I can see the bug in console. I am calling this url when trying to uploading image using ajax. and file name sending the query string.


RE: issue during upgrading 2.2.4 to 3.0 - mwhitney - 09-01-2015

The error message indicates that a session was started before the session library was loaded. Without code or even the full text of the error messages, I can't really tell you what's going on. I certainly wouldn't put the file name in a query string when I'm sending a POST, but that probably has nothing to do with the session error or the Uploader::$load error for which you can't even see the filename/line number in the screenshot.

If you didn't change the JavaScript going from CI 2.x to 3.0, then the JavaScript probably isn't the problem, unless your configuration changed in some way which is significant to the error at hand.