CodeIgniter Forums
Mod_rewrite not working - Printable Version

+- CodeIgniter Forums (https://forum.codeigniter.com)
+-- Forum: Using CodeIgniter (https://forum.codeigniter.com/forum-5.html)
+--- Forum: Installation & Setup (https://forum.codeigniter.com/forum-9.html)
+--- Thread: Mod_rewrite not working (/thread-63281.html)



Mod_rewrite not working - roy1523 - 10-15-2015

Hello,

I just started with CodeIgniter, I did the tutorial and now I'm at the General topic - CodeIgniter URLs: https://codeigniter.com/user_guide/general/urls.html

I modified the .htaccess file that comes with the CodeIgniter install, I added the following:
Code:
RewriteEngine On
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule ^(.*)$ index.php/$1 [L]

So now the complete .htaccess file is:

Code:
RewriteEngine On
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule ^(.*)$ index.php/$1 [L]

<IfModule authz_core_module>
    Require all denied
</IfModule>
<IfModule !authz_core_module>
    Deny from all
</IfModule>

I'm using MAMP as webserver, it runs on localhost:8888
Here is a link to my httpd.conf file: http://pastebin.com/Am0ew0C0

the codeigniter folder is located at: /Users/Roy/Websites/CodeIgniter-3.0.2

Please tell me if I'm posting this on the wrong forum, I'm hoping someone knows why this isn't working because I'm pretty lost.


RE: Mod_rewrite not working - macruzgi - 10-15-2015

Greetings, just have that problem with PCI 3.0.1, I configured the htacces file is as follows:

#Rewrite /jicaro es el nombre de la carpeta del proyecto
RewriteEngine On
RewriteBase /jicaro
RewriteCond %{REQUEST_URI} ^system.*
RewriteRule ^(.*)$ /index.php/$1 [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule ^(.*)$ index.php/$1 [L]

I do not work, and please thank your help, I looking in the manual but still can not find the solution.
First of all, Thanks!


RE: Mod_rewrite not working - ignitedcms - 10-15-2015

I'm on mamp and this works for me

Try using the following .htaccess file

RewriteEngine on
RewriteCond $1 !^(index\.php|resources|robots\.txt)
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule ^(.*)$ index.php/$1 [L,QSA]

Then in the config.php make sure you remove index.php

$config['index_page'] = '';


RE: Mod_rewrite not working - CroNiX - 10-16-2015

Some servers need a ? after index.php
RewriteRule ^(.*)$ index.php?/$1 [L,QSA]


RE: Mod_rewrite not working - InsiteFX - 10-19-2015

This always works for me, from FuelPHP.

PHP Code:
<IfModule mod_rewrite.c>

 
   # Make sure directory listing is disabled
    
Options +FollowSymLinks -Indexes
    RewriteEngine on

    
# NOTICE: If you get a 404 play with combinations of the following commented out lines
    #AllowOverride All
    #RewriteBase /wherever/ci/is
    
RewriteBase /

    
# Restrict your site to only one domain
    # Important USE ONLY ONE OF THESE OPTIONS BELOW!

    # Option 1: To rewrite "www.domain.com -> domain.com" uncomment the following lines.
    #RewriteCond %{HTTPS} !=on
    #RewriteCond %{HTTP_HOST} ^www\.(.+)$ [NC]
    #RewriteRule ^(.*)$ http://%1/$1 [R=301,L]

    # Option 2: To rewrite "domain.com -> www.domain.com" uncomment the following lines.
    #RewriteCond %{HTTPS} !=on
    #RewriteCond %{HTTP_HOST} !^www\..+$ [NC]
    #RewriteCond %{HTTP_HOST} (.+)$ [NC]
    #RewriteRule ^(.*)$ http://www.%1/$1 [R=301,L]

    # Option 3: Remove index.php from URL
    
RewriteCond %{HTTP:X-Requested-With}    !^XMLHttpRequest$
    
RewriteCond %{THE_REQUEST}                ^[^/]*/index\.php [NC]
    
RewriteRule ^index\.php(.*)$            $[R=301,NS,L]

    
# Send request via index.php (again, not if its a real file or folder)
    
RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond 
%{REQUEST_FILENAME} !-d

    RewriteCond 
$^(robots\.txt|favicon\.ico|style\.css)

    
# deal with php5-cgi first
    
<IfModule mod_fcgid.c>
        
RewriteRule ^(.*)$ index.php?/$[QSA,L]
    </
IfModule>

    <
IfModule !mod_fcgid.c>

        
# for normal Apache installations
        
<IfModule mod_php5.c>
            
RewriteRule ^(.*)$ index.php/$[QSA,L]
        </
IfModule>

        
# for Apache FCGI installations
        
<IfModule !mod_php5.c>
            
RewriteRule ^(.*)$ index.php?/$[QSA,L]
        </
IfModule>

    </
IfModule>

</
IfModule