CodeIgniter Forums
Page Editing - Printable Version

+- CodeIgniter Forums (https://forum.codeigniter.com)
+-- Forum: Using CodeIgniter (https://forum.codeigniter.com/forumdisplay.php?fid=5)
+--- Forum: General Help (https://forum.codeigniter.com/forumdisplay.php?fid=24)
+--- Thread: Page Editing (/showthread.php?tid=64207)



Page Editing - majimazuri21 - 01-27-2016

Hello Everyone


I have been using Codeigniter for a while; but I have encountered a certain problem.
When editing my project, changes takes time to take place; I have tried to stop cache and clearing page caches without any success; this highly frustrate me. Someone help me please

Tank you Sad Sad Sad Sad


RE: Page Editing - kilishan - 01-27-2016

If you are running a newer version of PHP and have the opcode cache turned on, it seems to keep the opcodes cached for about a minute. Turn off opcode caching in your local environment and that should go back to normal.


RE: Page Editing - majimazuri21 - 01-27-2016

Hi Kilishan;

Thank you very-much for your response; my application is hosted in shared hosting; is there ability to turn off opcode cache?

Thanks


RE: Page Editing - kilishan - 01-27-2016

Depends on your provider, but probably not. I believe it typically requires some settings in the php.ini file, which is something shared hosting typically doesn't give access to modify for security reasons.

I would suggest developing on a local machine, though, and only uploading to shared hosting afterword, when you're sure things are how you want them. Much better in the long run.


RE: Page Editing - majimazuri21 - 01-28-2016

Thank you for your helpful suggestions;


RE: Page Editing - majimazuri21 - 02-01-2016

Thank you again Kilishan;

I thanks GOD I have got a solution; in my hosting there was a Varnish cache turned on; the solution was to turn it off for my respective domain containing my codeigniter web application.

enjoy;


RE: Page Editing - kilishan - 02-01-2016

(02-01-2016, 05:19 AM)[email protected] Wrote: Thank you again Kilishan;

I thanks GOD I have got a solution; in my hosting there was a Varnish cache turned on; the solution was to turn it off for my respective domain containing my codeigniter web application.

enjoy;

Glad you found a solution. I didn't even think to mention Varnish, though I should have. I guess I associate that with larger, high-capacity apps, and mentally skip over the idea that they are used by lots of hosting providers.


RE: Page Editing - ivantcholakov - 02-01-2016

If the provider has activated APC (on older PHP), see this article: https://kaspars.net/blog/web-development/standalone-script-for-clearing-apc-cache