CodeIgniter Forums
Codeigniter 4 Setup On Bitnami - Printable Version

+- CodeIgniter Forums (https://forum.codeigniter.com)
+-- Forum: CodeIgniter 4 (https://forum.codeigniter.com/forum-28.html)
+--- Forum: CodeIgniter 4 Discussion (https://forum.codeigniter.com/forum-31.html)
+--- Thread: Codeigniter 4 Setup On Bitnami (/thread-65559.html)



Codeigniter 4 Setup On Bitnami - wolfgang1983 - 06-26-2016

I have got a question.

I can set up codeigniter 3 on bitnami fine no issues.

I did the usual setup with codeigniter 4

PHP Code:
<Directory "C:\Bitnami\wampstack-5.6.22-0/frameworks/codeigniter4/public/">
 
   Options +MultiViews
    AllowOverride None
    
<IfVersion 2.3 >
 
       Order allow,deny
        Allow from all
    
</IfVersion>
 
   <IfVersion >= 2.3>
 
       Require all granted
    
</IfVersion>
 
   
    



</Directory

PHP Code:
Alias /codeigniter4"C:\Bitnami\wampstack-5.6.22-0/frameworks/codeigniter4/public/"
Alias /codeigniter4 "C:\Bitnami\wampstack-5.6.22-0/frameworks/codeigniter4/public"

Include "C:\Bitnami\wampstack-5.6.22-0/frameworks/codeigniter4/conf/httpd-app.conf" 

PHP Code:
# Bitnami applications installed in a prefix URL
Include "C:/Bitnami/wampstack-5.6.22-0/frameworks/symfony/conf/httpd-prefix.conf"
Include "C:/Bitnami/wampstack-5.6.22-0/frameworks/codeigniter/conf/httpd-prefix.conf"
Include "C:/Bitnami/wampstack-5.6.22-0/frameworks/codeigniter4/conf/httpd-prefix.conf"
Include "C:/Bitnami/wampstack-5.6.22-0/frameworks/laravel/conf/httpd-prefix.conf"
Include "C:/Bitnami/wampstack-5.6.22-0/apps/phpmyadmin/conf/httpd-prefix.conf" 


Still shows up with white page when http://localhost/codeigniter4 any suggestions?


RE: Codeigniter 4 Setup On Bitnami - ciadmin - 06-26-2016

You need PHP7, not 5.6.22.
You need to point your server to the public folder.

You asked this in the announcement thread already ...http://forum.codeigniter.com/thread-65544-post-333812.html#pid333812