CodeIgniter Forums
Codeigniter 4 Error on XAMPP - Printable Version

+- CodeIgniter Forums (https://forum.codeigniter.com)
+-- Forum: CodeIgniter 4 (https://forum.codeigniter.com/forum-28.html)
+--- Forum: CodeIgniter 4 Support (https://forum.codeigniter.com/forum-30.html)
+--- Thread: Codeigniter 4 Error on XAMPP (/thread-65773.html)



Codeigniter 4 Error on XAMPP - manojrhr - 07-22-2016

Hi,

I am testing Codeigniter 4 on my windows 7 PC. I have downloaded the codeigniter 4 from github and copied all the files to my htdocs folder of my XAMPP installation on Windows 7. 

But I am getting an error


Quote:Fatal error: Default value for parameters with a class type hint can only be NULL in C:\xampp\htdocs\CodeIgniter4-develop\system\Config\DotEnv.php on line 121


Is there something I am missing?


RE: Codeigniter 4 Error on XAMPP - Avenirer - 07-22-2016

what php version?


RE: Codeigniter 4 Error on XAMPP - manojrhr - 07-22-2016

(07-22-2016, 07:26 AM)Avenirer Wrote: what php version?

Its PHP Version 5.5.9


RE: Codeigniter 4 Error on XAMPP - kilishan - 07-22-2016

Definitely sounds like you're not running PHP7 here. Try running under PHP7 and that should go away.


RE: Codeigniter 4 Error on XAMPP - manojrhr - 07-22-2016

(07-22-2016, 07:28 AM)kilishan Wrote: Definitely sounds like you're not running PHP7 here. Try running under PHP7 and that should go away.

Thank you so much? Can I get the link to Codeigniter 4 documentation.


RE: Codeigniter 4 Error on XAMPP - Avenirer - 07-22-2016

https://bcit-ci.github.io/CodeIgniter4/index.html


RE: Codeigniter 4 Error on XAMPP - InsiteFX - 07-22-2016

XAMPP just released a version 7.0.8 for windows, but php.net has a newer security fix for php 7.0.9