CodeIgniter Forums
Code Igniter blocking access to /cgi-bin - Printable Version

+- CodeIgniter Forums (https://forum.codeigniter.com)
+-- Forum: Archived Discussions (https://forum.codeigniter.com/forum-20.html)
+--- Forum: Archived General Discussion (https://forum.codeigniter.com/forum-21.html)
+--- Thread: Code Igniter blocking access to /cgi-bin (/thread-6727.html)

Pages: 1 2


Code Igniter blocking access to /cgi-bin - El Forum - 03-12-2008

[eluser]yello[/eluser]
again, not working...

I really don't know what's up... maybe it's a problem with my host (hostgator)?


Code Igniter blocking access to /cgi-bin - El Forum - 03-12-2008

[eluser]Techie-Micheal[/eluser]
Hmmm. I'll give it a go. Actually, might as well right now since I'll probably forget later.

Edit: I can't right now, because my host does things a little differently ... They don't actually have a cgi-bin. Kinda funky.


Code Igniter blocking access to /cgi-bin - El Forum - 03-12-2008

[eluser]Symcrapico[/eluser]
Yello, did you get it working?

Ive encountered the exact same problem today. Ive tried every solutions mentionned in this thread and none seem ed to be working!

If you got it working, please let us know here.

Thanks

S


Code Igniter blocking access to /cgi-bin - El Forum - 03-12-2008

[eluser]Techie-Micheal[/eluser]
Well, let's think about this. Basically the only thing that sets cgi-bin apart from other directories is that it has ExecCGI enabled on it (which enables perl/python/ruby/etc.), right?


Code Igniter blocking access to /cgi-bin - El Forum - 03-13-2008

[eluser]Symcrapico[/eluser]
I've looked at the httpd.conf file on my dedicated server (WHM) and I think this might be the problem:

Quote:<Directory "/usr/local/apache/cgi-bin">
AllowOverride None
Options None
Order allow,deny
Allow from all
</Directory>

Maybe the AllowOverride None has something to do with it, but I dont think so since I commented it out and restarted apache and didnt changed a thing. I also try AllowOverride all, didnt worked either.

Please someone help us with that...I badly need to get it working!


Code Igniter blocking access to /cgi-bin - El Forum - 03-13-2008

[eluser]Techie-Micheal[/eluser]
[quote author="Symcrapico" date="1205471793"]I've looked at the httpd.conf file on my dedicated server (WHM) and I think this might be the problem:

Quote:<Directory "/usr/local/apache/cgi-bin">
AllowOverride None
Options None
Order allow,deny
Allow from all
</Directory>

Maybe the AllowOverride None has something to do with it, but I dont think so since I commented it out and restarted apache and didnt changed a thing. I also try AllowOverride all, didnt worked either.

Please someone help us with that...I badly need to get it working![/quote] Sorry, but I don't have access to a server with this kind of setup right now.


Code Igniter blocking access to /cgi-bin - El Forum - 03-13-2008

[eluser]Techie-Micheal[/eluser]
Okay, I setup a quick environment on my local machine, but it is running Windows.

So, here's what the directory structure looks like.

Code:
vhosts/local.michealcottingham.com/
- logs/
- www/
   - <public content>
- ci/
   - <the ci system dir>
   - <the ci application dir>
- cgi-bin/
   - <perl/etc. files>

Simple enough.

Here's my relevant Apache config:

Code:
# local.michealcottingham.com
<VirtualHost 127.0.0.1:80>
    ServerAdmin [email protected]
    DocumentRoot C:/xampp/vhosts/local.michealcottingham.com/www/
    ServerName local.michealcottingham.com
    ServerAlias local.michealcottingham.com www.local.michealcottingham.com
    ErrorLog C:/xampp/vhosts/local.michealcottingham.com/logs/error.log
    CustomLog C:/xampp/vhosts/local.michealcottingham.com/logs/access.log combined

    <Directory "C:/xampp/vhosts/local.michealcottingham.com/cgi-bin">
        AllowOverride None
        Options ExecCGI
        Order allow,deny
        Allow from all
    </Directory>
</VirtualHost>

Here's my .htaccess file:

Code:
RewriteEngine On
RewriteBase /
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_URI} !/community
RewriteCond %{REQUEST_URI} !/templates
RewriteCond %{REQUEST_URI} !/blaze

RewriteRule ^(.*)$ index.php/$1 [L]

And cgi-bin works. o_O


Code Igniter blocking access to /cgi-bin - El Forum - 03-13-2008

[eluser]Techie-Micheal[/eluser]
Ah ha! Found a misconfiguration in my setup (not sure how it was working, but eh). I'm now able to reproduce the problem.


Code Igniter blocking access to /cgi-bin - El Forum - 03-13-2008

[eluser]Techie-Micheal[/eluser]
And now it works. I'm too tired. I'm not sure what I've done. Tongue I'll try and take a look at it again tomorrow.


Code Igniter blocking access to /cgi-bin - El Forum - 03-23-2008

[eluser]Référencement Google[/eluser]
I came with the same issue on a webserver. I solved it using a rule before all my rewrite conditions:

Code:
ErrorDocument 401 index.php

This is originally a wordpress issue too, you can see here:
http://wordpress.org/support/topic/89515

Hope this have helped some people !