CodeIgniter Forums
Problems with MAMP - Printable Version

+- CodeIgniter Forums (https://forum.codeigniter.com)
+-- Forum: Archived Discussions (https://forum.codeigniter.com/forum-20.html)
+--- Forum: Archived Development & Programming (https://forum.codeigniter.com/forum-23.html)
+--- Thread: Problems with MAMP (/thread-7213.html)



Problems with MAMP - El Forum - 03-30-2008

[eluser]Unknown[/eluser]
Hey all, just got my first mac the other day. I've got a slight problem with MAMP and CI. When I start a CI application it finds the welcome controller fine so I'm guessing its not the routing. However, when I go index.php/posts/index I just get a blank page with no errors, I've made the controller and views. I then fiddled with the config file for an hour with no luck, so I removed index.php with a .htaccess file and now when I search for my controller it's trying to take my to posts/index as directories. I have the rewrite_module uncommented in my httpd.conf.

I've searched the forum and tried many things in my base_url such as http://localhost/~John/myapp/, still no luck. I have made the ports default so I don't need to use 8888.

Anyone have any ideas?


Problems with MAMP - El Forum - 03-30-2008

[eluser]GSV Sleeper Service[/eluser]
from my experience with CI, a completely blank page sometimes means a php syntax error in your controller or view.
you can check the syntax by running
Code:
php -l /path/to/your/controller.php
from the terminal.


Problems with MAMP - El Forum - 03-30-2008

[eluser]Unknown[/eluser]
Thanks for the reply, I started again and it seems to work now. Is there some sort of reason why on windows CI will tell me I've got a parse error but so far it won't on mac. Now I've just gotta get CocoaMySQL working.


Problems with MAMP - El Forum - 03-30-2008

[eluser]jbowman[/eluser]
windows isn't as case sensitive as *nix/mac, that's usually the problem.

Find your apache error log and check it after the failed requests to get the error message supplied by php