CodeIgniter Forums
CodeIgniter 4 installation shall not require composer - Printable Version

+- CodeIgniter Forums (https://forum.codeigniter.com)
+-- Forum: CodeIgniter 4 (https://forum.codeigniter.com/forum-28.html)
+--- Forum: CodeIgniter 4 Discussion (https://forum.codeigniter.com/forum-31.html)
+--- Thread: CodeIgniter 4 installation shall not require composer (/thread-72358.html)

Pages: 1 2


RE: CodeIgniter 4 installation shall not require composer - Pertti - 12-12-2018

Best solution is to give developer the choice, if they want just files, here you go, if you want to use composer, here you go, which I believe is how it's currently planned to be released.

Everyone's included, no-one is upset that they can't use the framework the way they want to use it, but most importantly, CI isn't exclusively tied to any 3rd party service that CI team has no control over.