CodeIgniter Forums
[split] Installer didn't - Printable Version

+- CodeIgniter Forums (https://forum.codeigniter.com)
+-- Forum: CodeIgniter 4 (https://forum.codeigniter.com/forum-28.html)
+--- Forum: CodeIgniter 4 Support (https://forum.codeigniter.com/forum-30.html)
+--- Thread: [split] Installer didn't (/thread-72464.html)



[split] Installer didn't - emilio - 12-22-2018

Good evening

I tried to install via Composer CodeIgniter 4 on Debian 9.6 and this is the message

[InvalidArgumentException]
Could not find package codeigniter4/framework with stability stable.

is there an other method to install?

Thank You in advance

Emilio Franco


RE: [split] Installer didn't - ciadmin - 12-22-2018

Until CI4 is stable, you will need to tell composer that you are willing to install the alpha ...
Code:
composer create-project codeigniter4/framework PROJECT_ROOT -s alpha

I realize that the post-install script only runs on Linux (and references the wrong file), and that needs fixing too.

I will update the docs, sorry!


RE: [split] Installer didn't - emilio - 12-24-2018

(12-22-2018, 10:18 PM)ciadmin Wrote: Until CI4 is stable, you will need to tell composer that you are willing to install the alpha ...
Code:
composer create-project codeigniter4/framework PROJECT_ROOT -s alpha

I realize that the post-install script only runs on Linux (and references the wrong file), and that needs fixing too.

I will update the docs, sorry!

Thank You very much, and have a great X-MAS


RE: [split] Installer didn't - emilio - 12-24-2018

(12-24-2018, 06:43 PM)emilio Wrote:
(12-22-2018, 10:18 PM)ciadmin Wrote: Until CI4 is stable, you will need to tell composer that you are willing to install the alpha ...
Code:
composer create-project codeigniter4/framework PROJECT_ROOT -s alpha

I realize that the post-install script only runs on Linux (and references the wrong file), and that needs fixing too.

I will update the docs, sorry!

Thank You very much, and have a great X-MAS
Yes it runs on Linux (Debian 9.6) but now this is the result

[InvalidArgumentException]                                                   
  Could not find package codeigniter4/framework with stability alpha in a ver  
  sion installable using your PHP version 7.0.33.


RE: [split] Installer didn't - ciadmin - 12-24-2018

(12-24-2018, 06:47 PM)emilio Wrote: Yes it runs on Linux (Debian 9.6) but now this is the result

[InvalidArgumentException]                                                   
  Could not find package codeigniter4/framework with stability alpha in a ver  
  sion installable using your PHP version 7.0.33.

You need PHP 7.1 or higher. This is clear on both the user guide and the composer package page.

https://codeigniter4.github.io/CodeIgniter4/intro/requirements.html
https://packagist.org/packages/codeigniter4/framework


RE: [split] Installer didn't - emilio - 12-27-2018

(12-24-2018, 07:19 PM)ciadmin Wrote:
(12-24-2018, 06:47 PM)emilio Wrote: Yes it runs on Linux (Debian 9.6) but now this is the result

[InvalidArgumentException]                                                   
  Could not find package codeigniter4/framework with stability alpha in a ver  
  sion installable using your PHP version 7.0.33.

You need PHP 7.1 or higher. This is clear on both the user guide and the composer package page.

https://codeigniter4.github.io/CodeIgniter4/intro/requirements.html
https://packagist.org/packages/codeigniter4/framework

Thank You, I updated PHP to 7.2 version and at the end of installation by Composer i receive this message

Script bash admin/setup.sh handling the post-update-cmd event returned with error code 127