CodeIgniter Forums
BackendPro 0.6.1 - Printable Version

+- CodeIgniter Forums (
+-- Forum: Archived Discussions (
+--- Forum: Archived Libraries & Helpers (
+--- Thread: BackendPro 0.6.1 (/showthread.php?tid=7381)

BackendPro 0.6.1 - El Forum - 09-06-2010

[quote author="adamp1" date="1283779109"]From looking at the code. Its failing to create the resource in acl_resources.php line 130. Off the top of my head I don't know why its failing, some debuging is my only solution. Is the sql failing?[/quote]

I tried to send you an PM, but it doesn't seem to work - I cannot see them in my outbox. Ok, I will try to attach the debug output here. -> attachment removed, because the problem is in another place.

I think it fails in "Khacl.php" line 540, but I didn't see why. Attached you find the debug output after the try to add the resource "Website" with parent "Site". The database is pure BackendPro 0.6.1 without any other data.

EDIT (7:48 PM):
This query runs at Khacl.php line 540 ("xds_1_" is my table prefix)
SELECT * FROM (`xds_1_be_acl_resources`) WHERE `name` = 'Website' LIMIT 1
If I run it in phpMyAdmin it outputs an empty result.

EDIT (8:27 PM):
The line 600 in Khacl.php
returns FALSE in any case!

If I switch on "db_debug" the following error is shown:
Quote:A Database Error Occurred

Error Number: 1366

Incorrect integer value: 'NULL' for column 'link' at row 1

INSERT INTO `xds_1_be_acl_resources` (`lft`, `rgt`, `name`, `link`) VALUES (2, 3, 'Website', 'NULL')

So, if I set line 542 of Khacl.php from
$link = is_numeric($link)?$link:'NULL';
$link = is_numeric($link)?$link:NULL;
it results in this message:
Quote:A Database Error Occurred

Error Number: 1452

Cannot add or update a child row: a foreign key constraint fails (`xds2`.`xds_1_be_resources`, CONSTRAINT `xds_1_be_resources_ibfk_1` FOREIGN KEY (`id`) REFERENCES `xds_1_be_acl_resources` (`id`) ON DELETE CASCADE)

INSERT INTO `xds_1_be_resources` (`id`) VALUES (0)
The resource was inserted in "be_acl_resources", but not in "be_resources"!

doesn't return the inserted id of the resource.

EDIT (8 Sep, 5:32 PM):

Any idea? I didn't found a solution till now. Thanks for any help!

BackendPro 0.6.1 - El Forum - 09-10-2010

[quote author="adamp1" date="1274187478"]Not quite. What you should do is as follows:

Group 1 - Your 100% correct on this one
Group 2 - Since these users are accessing I take it a logged in area you use public_controller but put a check() on the controller/method you want.
Group 3 - Only administrations should be able to get to the Control Panel, so only ever use admin_controller for that, never for group 2.[/quote]

Can i just query this,
I allow editors access to a project by creating a group as a sub group of the administrator group and allowing acccess to control panel, but deny access to system,
then extend the backend menu and create resources under that and grant access to those resources.

users then use the back end for tasks and its clearly seperated from teh front end.

I do have a issue that I cant login under ie8 teh login screen just comes back to its self on submit? any help I did not find any note of this issue but the thread is huge!

great product bythe way

BackendPro 0.6.1 - El Forum - 09-20-2010


I've just installed BEP but I'm not getting prompted for a login, what do I need to add to make this work?

Thank you!

BackendPro 0.6.1 - El Forum - 09-21-2010

if its set up correclty the default codeigniter fornt end should have been replaced by one showing a welcome to bep and a login link! alt try http://yoururl/auth/login

if you want a good walk through of hopw to make us eof BeP try this article :

helped me out loads

BackendPro 0.6.1 - El Forum - 09-21-2010

Thanks for the pointers, I think I must've set it up wrong as I'm just getting a 404 - will try again...

BackendPro 0.6.1 - El Forum - 09-21-2010

Hello again,

I had another go at the installation, but can't seem to get it to work - I've copied the folders over to the CI directories, and the db has been populated, but i'm getting this

Quote:An Error Was Encountered

Unable to load the requested class: status

when i go here:

Any ideas? 8-/

BackendPro 0.6.1 - El Forum - 09-21-2010

Also, I'm getting this where my home page was:
Quote:An Error Was Encountered
Unable to load the requested file: welcome_message.php

BackendPro 0.6.1 - El Forum - 09-21-2010

Ok, I've changed to default controller back to 'site' in routes.php and it shows my home page again.

When I set up CI I moved the application folder out of system to root, is this the problem?

I've got the BEP folders as follows:

/install *need to delete this
/application/*BEP files in the corresponding folders

the rest of my folders


have i done this wrong?

BackendPro 0.6.1 - El Forum - 09-21-2010

you dhould have simply copies bep over the top of your CI files

default is


if you follow the portfolio walk through you get


you simply drag the bep files over the top of your root folder with ci in it so it overwrites the system folder and everything

then run bep install having made ethe changes for php5.x as needed
and chmoded any files that are required.

BackendPro 0.6.1 - El Forum - 10-15-2010

Question regarding User Authentication System

I'd like to add a login form on all the pages in the front end for members.

What is the best way to do it.

Any example codes?

Thanks in advance.