CodeIgniter Forums
should I switch to php 7.2? - Printable Version

+- CodeIgniter Forums (https://forum.codeigniter.com)
+-- Forum: Using CodeIgniter (https://forum.codeigniter.com/forumdisplay.php?fid=5)
+--- Forum: General Help (https://forum.codeigniter.com/forumdisplay.php?fid=24)
+--- Thread: should I switch to php 7.2? (/showthread.php?tid=74651)



should I switch to php 7.2? - richb201 - 10-19-2019

I am using php 5.6 but I am having trouble building a specific Docker image with it. If I switch of the php 7.2, can I expect everything else in my app to break?


RE: should I switch to php 7.2? - Paradinight - 10-20-2019

(10-19-2019, 10:48 PM)richb201 Wrote: I am using php 5.6 but I am having trouble building a specific Docker image with it. If I switch of the php 7.2, can I expect everything else in my app to break?
CI 3.1.11 works with PHP 7.3. You code could not work, because of deprecated feature. Check the docs and test it Smile

- https://www.php.net/manual/en/migration70.php
- https://www.php.net/manual/en/migration71.php
- https://www.php.net/manual/en/migration72.php
- https://www.php.net/manual/en/migration73.php
- https://www.php.net/manual/en/migration74.php


RE: should I switch to php 7.2? - InsiteFX - 10-20-2019

If I were you I would switch to PHP 7.3.10 that's what I am running.


RE: should I switch to php 7.2? - dave friend - 10-20-2019

(10-19-2019, 10:48 PM)richb201 Wrote: I am using php 5.6 but I am having trouble building a specific Docker image with it. If I switch of the php 7.2, can I expect everything else in my app to break?

PHP 7.2 leaves Active Support mode at the end of next month (30 Nov 2019) and will only get security updates after that until 30 Nov 2020.

You should go to PHP 7.3

PHP Supported Versions


RE: should I switch to php 7.2? - richb201 - 10-22-2019

Turns out that Grocery Crud, which I use, doesn't work with 7.3. So 7.2, it has to be...


RE: should I switch to php 7.2? - dave friend - 10-22-2019

(10-22-2019, 08:11 AM)richb201 Wrote: Turns out that Grocery Crud, which I use, doesn't work with 7.3. So 7.2, it has to be...

I don't think that is true. The one issue I know of was fixed with version 1.6.3 which was released last March.