CodeIgniter Forums
pt-br Translation (Tradução para pt-br) - Printable Version

+- CodeIgniter Forums (https://forum.codeigniter.com)
+-- Forum: Using CodeIgniter (https://forum.codeigniter.com/forum-5.html)
+--- Forum: Installation & Setup (https://forum.codeigniter.com/forum-9.html)
+--- Thread: pt-br Translation (Tradução para pt-br) (/thread-75939.html)



pt-br Translation (Tradução para pt-br) - almeida.gab - 03-30-2020

Hello guys,

My question is simple actually. I would like to know how to change the language of CI 4. Because I believe it's different from previous versions.


Oi Pessoal,

A minha dúvida é simples na verdade. Gostaria de saber como mudar a linguagem do CI 4. Pois acredito que seja diferente das versões anteriores.


RE: pt-br Translation (Tradução para pt-br) - jreklund - 03-30-2020

You will find all information about the topic (and download translation) on Github. Same link are available from our website -> Download -> Translations.


RE: pt-br Translation (Tradução para pt-br) - George Rangel - 04-06-2020

I think there is a problem when trying to install the translation using composer.

1 - https://codeigniter.com/user_guide/installation/installing_composer.html?highlight=composer%20require%20codeigniter4%20translations# we see 
Code:
composer require codeigniter4/translations @rc
This works, but the translation folder is installed in "/vendor/codeigniter4/translations/Language" path, since must be in "/app/Language". Its installing v4.0.0-rc.3 version.


2 - https://codeigniter.com/user_guide/installation/installing_git.html?highlight=composer%20require%20codeigniter4%20translations. the same, but with the code
Code:
composer require codeigniter4/translations @beta

3 - https://codeigniter.com/user_guide/outgoing/localization.html?highlight=composer%20require%20codeigniter4%20translations
Code:
composer require codeigniter4/translations

https://codeigniter.com/user_guide/outgoing/localization.html?highlight=composer%20require%20codeigniter4%20translations
Get an error: "[InvalidArgumentException] Could not find a version of package codeigniter4/translations matching your minimum-stability (stable). Require it with an explicit version constraint allowing its desired stability."

So, I dont want to copy the folder. I want to use composer. What should I do?