Welcome Guest, Not a member yet? Register   Sign In
Search Results
    Thread: CodeIgniter v4.3.8 and v4.4.0 Released!
Post: RE: CodeIgniter v4.3.8 and v4.4.0 Released!

kenjis Wrote: (09-07-2023, 02:34 PM) -- @"chaos" Try https://github.com/codeigniter4/CodeIgniter4/pull/7901 -- Thank you very much. Should I patch manually the files and then upgrade when a next ve...
20,396 Views
37 Replies
09-08-2023, 02:53 AM
chaos
    Thread: CodeIgniter v4.3.8 and v4.4.0 Released!
Post: RE: CodeIgniter v4.3.8 and v4.4.0 Released!

kenjis Wrote: (09-07-2023, 01:53 AM) -- I cannot reproduce the error. I see "here". PHP Code: --
20,396 Views
37 Replies
09-07-2023, 07:11 AM
chaos
    Thread: CodeIgniter v4.3.8 and v4.4.0 Released!
Post: RE: CodeIgniter v4.3.8 and v4.4.0 Released!

kenjis Wrote: (09-06-2023, 02:05 PM) -- @"chaos" Show all backtrace and minimum code to reproduce the error. -- Sure. Put this in a Model: PHP Code: -- function replicate_bug () { $text =...
20,396 Views
37 Replies
09-07-2023, 12:42 AM
chaos
    Thread: CodeIgniter v4.3.8 and v4.4.0 Released!
Post: RE: CodeIgniter v4.3.8 and v4.4.0 Released!

kenjis Wrote: (08-28-2023, 06:16 PM) -- @"chaos" Did you customize Services for URI or Request? Since v4.4.0, Services::request()->getUri() must return the SiteURI instance. https://codeigniter4.gi...
20,396 Views
37 Replies
09-06-2023, 08:28 AM
chaos
    Thread: CodeIgniter v4.3.8 and v4.4.0 Released!
Post: RE: CodeIgniter v4.3.8 and v4.4.0 Released!

kenjis Wrote: (08-28-2023, 06:16 PM) -- @"chaos" Did you customize Services for URI or Request? Since v4.4.0, Services::request()->getUri() must return the SiteURI instance. https://codeigniter4.gith...
20,396 Views
37 Replies
08-28-2023, 11:06 PM
chaos
    Thread: CodeIgniter v4.3.8 and v4.4.0 Released!
Post: RE: CodeIgniter v4.3.8 and v4.4.0 Released!

Hi, after upgrade to 4.4.0 I have the following CRITICAL error: CRITICAL - 2023-08-28 17:49:27 --> assert($currentURI instanceof SiteURI) in SYSTEMPATH\Helpers\url_helper.php on line 34. 1 SYSTEM...
20,396 Views
37 Replies
08-28-2023, 09:09 AM
chaos
    Thread: CodeIgniter v4.3.8 and v4.4.0 Released!
Post: RE: CodeIgniter v4.3.8 and v4.4.0 Released!

Hi, after upgrade this gived null: $cfgoption_model = model('App\Model\CfgOptionModel'); dd($cfgoption_model); SOLVED: i replaced app\Model with app\Models... i wonder why it was working before...
20,396 Views
37 Replies
08-27-2023, 09:10 AM
chaos
    Thread: HTML 303
Post: RE: HTML 303

UPDATE: I found out that the Filter CSRF was causing the redirect. Now i have to find how to exclude some routes form the filter CSRF.
925 Views
3 Replies
02-19-2023, 01:01 PM
chaos
    Thread: 3rd party library
Post: 3rd party library

Note: I upgrade CI manually (not with composer update), so all the needed libraries are under 'system'. I need to install a 3rd party library with 'composer require' but if i do so, composer downgrad...
778 Views
0 Replies
02-18-2023, 03:34 AM
chaos
    Thread: HTML 303
Post: HTML 303

Hi, i am trying to integrate a payment system and i am required to write a callback page that returns HTML code 200. this is the controller i wrote as an example Code: -- public function callback...
925 Views
3 Replies
02-18-2023, 02:54 AM
chaos
    Thread: Upgrade to 4.3.1 help
Post: RE: Upgrade to 4.3.1 help

SOLVED, correct procedure: 1. Remove requirement "kint-php/kint": "^4.2" from composer.json 2. Run composer update (removed kint from vendor directory) 3. Copy system/ThirdParty/Kint/ from 4.3.1 ...
6,071 Views
12 Replies
01-30-2023, 04:04 AM
chaos
    Thread: Upgrade to 4.3.1 help
Post: RE: Upgrade to 4.3.1 help

kenjis Wrote: (01-28-2023, 02:57 AM) -- You should have "C:\laragon\www\chronicles_dev\system\ThirdParty/Kint/init.php". Why don't you have it? See https://github.com/codeigniter4/framework/blob/...
6,071 Views
12 Replies
01-29-2023, 09:25 AM
chaos
    Thread: Upgrade to 4.3.1 help
Post: RE: Upgrade to 4.3.1 help

Hello, if i remove that line, make composer update, then i have the following error.  Note: If I do not apply the manual changes to Kint Configuration suggested in the upgrade procedure everything wo...
6,071 Views
12 Replies
01-28-2023, 02:14 AM
chaos
    Thread: Upgrade to 4.3.1 help
Post: RE: Upgrade to 4.3.1 help

Thank you, spark problem solved. Now i have the following problem: when i apply the manual changes for Kint: Quote: -- app/Config/Kint.php has been updated for Kint 5.0.You need to replace:K...
6,071 Views
12 Replies
01-23-2023, 11:01 AM
chaos
    Thread: Upgrade to 4.3.1 help
Post: RE: Upgrade to 4.3.1 help

kenjis Wrote: (01-20-2023, 04:55 AM) -- It is the example when you installed CI via Composer. When you installed CI manually, download a new copy of the framework, and then copy the files. https://...
6,071 Views
12 Replies
01-21-2023, 12:08 AM
chaos
    Thread: Upgrade to 4.3.1 help
Post: Upgrade to 4.3.1 help

Hi, I upgraded manually CI to 4.1.3: 1. I copied system directory 2. I launched composer update Spark doesn't work anymore: Quote: -- [Error] Call to a member function getStatusCode() on n...
6,071 Views
12 Replies
01-20-2023, 04:19 AM
chaos
    Thread: SMTP fails on localhost
Post: RE: SMTP fails on localhost

akinuri Wrote: (05-25-2021, 11:34 AM) -- Guys, I appreciate the answers, but it appears none of you really examined the issue (the things I've posted). No, the problem is not about an antivirus so...
7,099 Views
11 Replies
11-23-2022, 10:50 AM
chaos
    Thread: Composer update doesn't work?
Post: Composer update doesn't work?

Hi, i tried to update CI to 4.2.9 on Windows 10 by running composer update, but nothing happens, what could be the reason? thanks
722 Views
1 Replies
11-02-2022, 09:21 AM
chaos

Theme © iAndrew 2016 - Forum software by © MyBB