Welcome Guest, Not a member yet? Register   Sign In
Search Results
    Thread: Email Class TLS 587 SASL ERROR
Post: RE: Email Class TLS 587 SASL ERROR

hmm.. SMTP works if I just switch to: 'protocol' => 'mail', ??
1,262 Views
2 Replies
05-27-2020, 10:01 PM
dbrooke
    Thread: Email Class TLS 587 SASL ERROR
Post: Email Class TLS 587 SASL ERROR

Codeigniter 3 Hello, seems I always have problems with CI and email. I run a properly configured Postfix / Ubuntu email server. I have several apps that authenticate via TLS port 587, with a va...
1,262 Views
2 Replies
05-27-2020, 05:48 PM
dbrooke
    Thread: Upgrading - Incremental or All at once?
Post: RE: Upgrading - Incremental or All at once?

After doing this, and with all presumed disclaimers ;-), it is really straight forward to just go straight to 3.1.11. Use a custom index.php (as the docs say) ie. In general, you can overwrite ...
2,197 Views
4 Replies
02-25-2020, 08:07 PM
dbrooke
    Thread: Upgrading - Incremental or All at once?
Post: RE: Upgrading - Incremental or All at once?

jreklund Wrote: (02-20-2020, 12:55 PM) -- You should replace your system folder with the latest version. And then follow all steps and replacing your files in application and doing the modifications....
2,197 Views
4 Replies
02-24-2020, 07:40 AM
dbrooke
    Thread: Upgrading - Incremental or All at once?
Post: Upgrading - Incremental or All at once?

Hello, In prepping for my upgrades from 3.1.0.. I'm looking at about 11 versions that I need to step through ( don't ask why I didn't do the step upgrades ). Re: https://codeigniter.com/user_guide...
2,197 Views
4 Replies
02-20-2020, 12:22 PM
dbrooke
    Thread: Force SSL for the site
Post: RE: Force SSL for the site

Mekaboo Wrote: (02-18-2020, 09:40 AM) -- Thank ya kindly  :heart: I have a Cpanel (HostGator)...will look into that later on as well as changing things within the config file. Thanks again!!! -- ...
3,615 Views
6 Replies
02-19-2020, 09:51 AM
dbrooke
    Thread: Force SSL for the site
Post: RE: Force SSL for the site

Hi, what platform? cPanel has this kind of redirect built in. Could also force HTTPS in .htacess (which you can google). Make sure to set your $config['base_url'] in application/config/config.php...
3,615 Views
6 Replies
02-18-2020, 09:35 AM
dbrooke
    Thread: sanitize textarea input for database insertion - best practice
Post: RE: sanitize textarea input for database insertion...

Thx for the feedback. Below seems to work fairly well. @InsiteFX.. I threw your code into my helper file. Thx. So here is what I have: Controller: - Validate: Code: -- $this->form_validatio...
5,182 Views
3 Replies
06-27-2019, 08:58 AM
dbrooke
    Thread: sanitize textarea input for database insertion - best practice
Post: sanitize textarea input for database insertion - b...

Hello, I thought I'd start this thread after a pretty thorough effort of searching / reading. My Situation I have a simple textarea that users are copy/pasting blocks of "text" (mostly from MS ...
5,182 Views
3 Replies
06-26-2019, 01:22 PM
dbrooke
    Thread: Authorize.Net (net\authorize\api) Helper
Post: RE: Authorize.Net (net\authorize\api) Helper

Here is a (very) brief overview of what I did to implement the basic charge CC sample code located here: https://github.com/AuthorizeNet/sample-code-php/blob/master/PaymentTransactions/charge-credit-...
2,709 Views
1 Replies
12-03-2018, 01:39 PM
dbrooke
    Thread: Authorize.Net (net\authorize\api) Helper
Post: Authorize.Net (net\authorize\api) Helper

Hello CI patrons. I am just starting an integration for the latest Authorize.Net PHP SDK.  I couldn't find an example for the newer net\authorize\api method, so I thought I'd start the thread he...
2,709 Views
1 Replies
11-29-2018, 12:10 PM
dbrooke
    Thread: [solved] allow query string (?p=) to one directory only
Post: RE: allow query string (?p=) to one directory only

I solved this in config.php by doing: $config['enable_query_strings'] = FALSE; and $config['permitted_uri_chars'] = 'a-z 0-9~%.:_\&\=\-'; Then editing the .htaccess file for the app that was ...
3,515 Views
3 Replies
05-02-2017, 07:51 AM
dbrooke
    Thread: [solved] allow query string (?p=) to one directory only
Post: RE: allow query string (?p=) to one directory only

Strange thing.. if I change one character of that first URL, it works fine.. it's the '&' char. before 'remote': domain.com/daforum/index.php?p=/?remote=http%3A%2F%2Fdomain.com%2Fforum%2F&locale= I ...
3,515 Views
3 Replies
04-28-2017, 04:37 PM
dbrooke
    Thread: [solved] allow query string (?p=) to one directory only
Post: RE: allow query string (?p=) to one directory only

FYI, this is an example of a call that is generated by the app that returns a 404: http://domain.com/daforum/index.php?p=/&remote=http%3A%2F%domain.com%2Fforum%2F&locale= The same call without the...
3,515 Views
3 Replies
04-28-2017, 03:47 PM
dbrooke
    Thread: [solved] allow query string (?p=) to one directory only
Post: [solved] allow query string (?p=) to one directory...

Hello CI'ers, I'm trying to embed a forum app into a codeigniter page. The problem I am running into is that the app is producing tradition query string calls which CI is not allowing.. ie. I get a 4...
3,515 Views
3 Replies
04-28-2017, 03:34 PM
dbrooke
    Thread: session & multi subdomains
Post: RE: session & multi subdomains

pws Wrote: (03-16-2017, 08:18 AM) -- hello, please can gve me full example? -- Please share the URL of both sites that you are dealing with.. thx. Donovan
2,447 Views
3 Replies
03-16-2017, 09:09 AM
dbrooke
    Thread: How best to Display an optional modal page
Post: RE: How best to Display an optional modal page

Not to be confused with 'Model'... Sounds good to me.. pretty straight forward to do stuff based off of cookie info. Did you try it? bootstrap has a pretty good Model that can be enacted easily.
1,519 Views
1 Replies
03-16-2017, 08:23 AM
dbrooke
    Thread: session & multi subdomains
Post: RE: session & multi subdomains

You have a limit set on your cookie domain path most likely.. look in the docs how to set the cookie path and set it to 'domain.com' rather than 'www.domain.com' or 'blog.domain.com'. Donovan
2,447 Views
3 Replies
03-16-2017, 08:07 AM
dbrooke
    Thread: Blank URI parameters
Post: RE: Blank URI parameters

No comments I guess?? I guess I'll start adding dummy fillers for any param that doesn't have a value.
1,864 Views
2 Replies
03-16-2017, 08:00 AM
dbrooke
    Thread: Blank URI parameters
Post: RE: Blank URI parameters

FYI, upon running more tests, in the call that doesn't work, it is clear that $subaction is being set to 254. That seems odd to me.. but maybe someone can explain a best practice here??
1,864 Views
2 Replies
03-15-2017, 12:09 PM
dbrooke

Theme © iAndrew 2016 - Forum software by © MyBB