• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Active Record Not Escaping

I am using $this->db->insert('table', $data)... When the data is inserted it is not escaped, but when profiler is enabled it is showing the query at the bottom with escapes.

CI version 1.6.3

PHP version 5.2.5

More Info:

The form info originally typed:

`Should'" Es\cape

Bad"quote" 'single'


attached is the profiler screenshot with the escapes

attached is screenshot of mysql with no escapes

[eluser]Pascal Kriete[/eluser]
I believe this is caused by the mysql cli client. It interprets the escapes when it displays the data. Try running it with the --raw or -r flag.

I get the same output in phpmyadmin... but I will try with the flags... I ran my own quotes and they are inserted and shown with no problems.

no different... add_slashes() inserts the slashes fine... but the db->insert method is not

I have installed everything on a work PC and run some tests. Still no escapes.

Digg   Delicious   Reddit   Facebook   Twitter   StumbleUpon  

  Theme © 2014 iAndrew  
Powered By MyBB, © 2002-2020 MyBB Group.