• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
404 regardless... [SOLVED]

Ok, very strangely, a fresh install of ci is working...

maybe it's capitalization differences in filenames?

Ok, my Betarel controller (code above) was named Betarel.php

All my controller filenames had the first letter capitalised.

Works fine on windows local machine, but I've just changed Betarel.php to betarel.php and now it works...

Not sure if this is an issue, just guessing here.

Should class Betarel extends Base_Controller
Be class Betarel extends Controller

Or maybe your are being redirected to that home directory. You do have home, right? And if it is, should it be home or /home?

Like I said, just guesses.

It's cool guys, got it going now.

It was simply that my controller filenames had the first letter capitalised.

Didn't seem to be a problem working local on windows though.

Damn, there goes the way I used to distinguish between my controller and view filenames in my text editor.


Digg   Delicious   Reddit   Facebook   Twitter   StumbleUpon  

  Theme © 2014 iAndrew  
Powered By MyBB, © 2002-2020 MyBB Group.