Welcome Guest, Not a member yet? Register   Sign In
Library not loading in Google App Engine

I am migrating my CI app to Google App Engine and I'm having issues with a 3rd party library not loading, and no error messages are present.

The library is from Go Cardless, and sits in the "third_party" folder.

It is loaded as shown below (this method works on a typical WAMP setup):

PHP Code:

But on GAE, I get a blank page, with no errors in the log.

If I comment out the 2nd line, where the library is loaded, the page will load fine.

Again, this approach worked flawlessly on a local WAMP setup and a remote VPS server.

Hard to know without having any errors present. My best guess would be the way you are pointing to the file is wrong. I have had this issue a few times. Works perfectly on a local machine and then doesn't work on the remote server. App engine I haven't tried yet as they are still in beta for php.
Have you got error reporting turned on in your index.php file?

PHP Code:
       case 'development':


Theme © iAndrew 2016 - Forum software by © MyBB