Welcome Guest, Not a member yet? Register   Sign In
CL_Auth not working in CI 1.6.3

I've been looking for an authentication library for CI and so recently downloaded and setup CL Auth http://www.jasonashdown.co.uk/cl_auth_doc/ I followed the installation instructions but when I tried to refresh my app I got the following error You have CL_Auth turned off. I'm using CI 1.6.3 and the documentation is minimal at best. Anybody out there managed to get it to work?

You need to activate it via your configuration file. In ./system/application/config/config.php, add:

$config['CL_Auth'] = TRUE;

I added that to my config file, that fixed the error, I then added
to one of controllers and this is the error I got:
An Error Was Encountered

Unable to load the requested file: .php

I thought may be this was a view problem,but all the views are present. Any idea why this is happening?

Again, it's a configuration issue. I'd suggest you check out the documentation for the library.

Fixed it, I hadn't added all the CL configurations to the config file, the poor documentation doesn't help but its all good now. Thanks for your help.

Theme © iAndrew 2016 - Forum software by © MyBB