Welcome Guest, Not a member yet? Register   Sign In
Autoloading database library on Windows causes silent CI failure

Here's the thread over in the general discussion forums.


Here's my addition to it:

I am, in fact, having this exact same problem. It appears to be platform specific though. This is only happening on Windows. The minute you go to add ‘database’ to the autoload[’libraries’] array in autoload.php, and try serving it on a Windows machine (I’m using Apache 2.2.4 for Windows, not sure about results on IIS), your CI app will fail to load, no errors, nothing logged anything! You just see a blank white page in your browser (the page doesn’t have any HTML source code either).

If you take this exact same CI setup and copy it over to a Linux machine, it works flawless. Sounds like a CI bug. I would really like to get this resolved.

[eluser]Derek Allard[/eluser]
Just a note. I've tested this recently on 2 separate windows machines, and I can't recreate. I've also tested BambooInvoice (app written in CI) against windows boxes many times, and it autoloads the db, and I still can't recreate. Any further info?

It has to be something with an apache install from the install .msi on their site, and php 5.2.3 from the windows installer on php's site. I tried using Uniform Server WAMP package (as mentioned previously in the other post), and CI worked fine on it.

Must be some weird config issue in the former?

[eluser]Derek Allard[/eluser]
Odd indeed... It is true that on Windows my testing system does run WinLamp.

Thanks for looking closer.

Not a problem. If I can narrow it down anymore, I will post it here.

Theme © iAndrew 2016 - Forum software by © MyBB