"No input file specified." error

I had been running CodeIgniter at my local server without any problems.
But after uploading the website to my hosting account, the system started to give the following error:

"No input file specified."

The homepage opens without any problems, but accessing the other controllers and functions gives the above mentioned error. What can be the problem?


Are the permissions for the subfolders set correctly?

I haven't changed any folders' and subfolders' permissions Smile
Which subfolders' and folders' permission must be changed? And changed to what? 777?


[eluser]Derek Allard[/eluser]
They only need to be readable, not 777 (unless you want that for another programming goal, but CI doesn't need it per se).

If you search these forums you'll find much reference to your error.

Oh yes, and welcome to CodeIgniter!

Thank you,
I'm glad to be a part of CodeIgniter community Smile

And I have solved the problem:
The website gives error when I want to open www.domain.com/index.php/blog/main
but it does not give when I open www.domain.com/index.php?blog/main

Only a question mark difference

[eluser]Derek Allard[/eluser]
Terrific! Welcome aboard 5lm!

Hey guys. I am getting the same issue but I tried both proposed solutions here: fix the CHMOD, use a ? in the URL, but neither solved the problem. Any other ideas?

[eluser]Derek Allard[/eluser]
Try opening up config.php and changing $config['uri_protocol'] to one of the other 3 options PenguinMan98.

No good. None of them worked. I'm on Godaddy's servers (which seem to be a common problem).

I'm using the following .htaccess file:
AddHandler x-httpd-php5 .php
AddHandler x-httpd-php .php4

RewriteEngine on
RewriteCond $1 !^(index\.php|images|robots\.txt)
RewriteRule ^(.*)$ /index.php/$1 [L]
and I've tried this:
AddHandler x-httpd-php5 .php
AddHandler x-httpd-php .php4

<IfModule mod_rewrite.c>
Options +FollowSymLinks
RewriteEngine on
RewriteBase /
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule ^(.*)$ index.php?/$1 [QSA,L]

Often what I will see is that the index page loads but I cannot link to the next page.

My site is X-Factor

(Any visitors please let me know if the flash video loads in a reasonable amount of time.)

Digg   Delicious   Reddit   Facebook   Twitter   StumbleUpon  

  Theme © 2014 iAndrew  
Powered By MyBB, © 2002-2021 MyBB Group.