• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[solved]Error Undefined property:

I have found the source of a new problem when calling my model function?

-I have checked my variables being passed that they are initilized!
-I have ensure the datbase library is autoloaded
-I have located the where the error is occurring see below.

Quote:A PHP Error was encountered

Severity: Notice

Message: Undefined property: Submit::$create_record

Filename: core/Model.php

Line Number: 50

echo "test breakpoint";       return;                                                           $this->submit_model->create_record($completedstaffrows, $completedeventrows); //error happens here?

Would a constructor fix this?

Function declaration in the model called Submit_model
public function create_record($completedstaffrows , $completedeventrows)
             //code here

Object property:

Object function:
$object->create_record($parameter, $parameter)

That does not seem to work.

I checked my autoloading of the model class and it is fine.

The function works fine also and submits to the database so unless this is a minor glitch (any way to remove the notification of the error).

This isn't an error. Its a notice. It is there because of what Aken said.

Somewhere you have done this.

Either outside of the model you have done this...


Or inside the model you have done this.


If all you are doing is calling the model, then exiting, I would suggest you check your constructor function.

Fixed it .

Was caused by a if statement on the function which did not have the "()" at the end.

Thanks for the help!

Digg   Delicious   Reddit   Facebook   Twitter   StumbleUpon  

  Theme © 2014 iAndrew  
Powered By MyBB, © 2002-2020 MyBB Group.