Welcome Guest, Not a member yet? Register   Sign In
SOLVED Unable to load the requested class: Globals

(This post was last modified: 07-03-2017, 08:45 AM by desbest.)

I uploaded my script from my computer to a website and when I load my script I get the 

Quote:Unable to load the requested class: Globals


The file I think being requested application/libraries/globals.php is lower case file name and inside config/autoload.php it says

$autoload['libraries'] = array('database', 'globals');

What is going on?

Is this working on your local machine?

If so, this is usually because of a capitalisation problem.

Is your globals file called 'Globals'?
Is your class called 'Globals'?

Both need to be uppercase first letter.

Best wishes,


It's fixed now. globals.php should have been Globals.php

Please add SOLVED to the subject line
On the package it said needs Windows 7 or better. So I installed Linux.

(07-03-2017, 07:58 AM)rtenny Wrote: Please add SOLVED to the subject line

The admins should add a mybb plugin to allow users to mark threads as solved.

Theme © iAndrew 2016 - Forum software by © MyBB