Poll: Should CI4 rewuire PHP7.3 as a minimum?
You do not have permission to vote in this poll.
Yes
48.89%
22 48.89%
No
40.00%
18 40.00%
Don't care
11.11%
5 11.11%
Total 45 vote(s) 100%
* You voted for this item. [Show Results]

  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Should CI-4 require PHP 7.3 ?

#11
(03-10-2019, 12:53 PM)Leo Wrote: I'm quite sure by that time ALL shared hostings will have 7.3 available (unless they're cheap and backwards then you shouldn't use 'em).

Not everyone is on shared hosting. We use CI at work for custom web apps on our intranet and you wouldn't believe how outdated our web servers are. It's very hard to convince the admins to upgrade the softwares because it's working as it is. So why take the risk...  Sad

Anyway. My opinion is that CI should require the lowest version possible, like it has always did in the past. If CI don't use any of the new feature, don't require the latest and greatest only for "marketing" purpose.
Test your translation files with Translation Tester
Reply

#12
I agree with puschie on this one:

Quote:Or use 7.2 as min and 7.3 as recommended
Support Development  • Practical CodeIgniter 3  • Vulcan - CLI Tools for CI4
Reply

#13
I did a search on the hosts and found that most still use PHP 5.6.40 ....... That's why I can not use Laravel and I probably will not be able to use CodeIgniter 4 ......
Reply

#14
(03-13-2019, 12:17 PM)includebeer Wrote: Anyway. My opinion is that CI should require the lowest version possible, like it has always did in the past. If CI don't use any of the new feature, don't require the latest and greatest only for "marketing" purpose.

I'll drink to that Smile

...and also add any supported PHP Version:

...otherwise itemised scripts where CI4 will possibly fail. This will give programmers to write workaround scripts if they require the relevant scripts ie email, databases.

https://en.wikipedia.org/wiki/PHP

PHP 5.6 supported until:  31 December 2018
CI4 Develop Site - progressing nicely - Thank you Smile
https://johns-jokes.cf/pictures

Reply

#15
(03-13-2019, 08:27 PM)nogueira Wrote: I did a search on the hosts and found that most still use PHP 5.6.40 ....... That's why I can not use Laravel and I probably will not be able to use CodeIgniter 4 ......

Curious as to the hosts you checked out. I check the "Top 10" (according to PC Magazine) and they all appear to offer at least PHP 7.2.
Reply

#16
Google Cloud finally got PHP 7.2 for App Engine Standard late last year. Moving to 7.3 may make CI4 incompatible with a large swath of cloud services- I'm not sure what AWS and Azure are doing.

Edit: Looks like Azure supports 5.6, 7.0, 7.2. AWS is whatever version you to install.
Reply

#17
IMO is better to require the oldest version possible. 
Some applications at my work are running on a ubuntu box with php 5.5.9 (not using CI though), and there is no reason to upgrade this server. 

I like the idea of deploying and never touch it again unless really required. 

If there is nothing really fancy in 7.3, then stick to 7.2
Reply

#18
It would be best if it supports lowest possible (the features used for developing the framework itself) up to latest.
In case the framework works 100% under 7.2 why to skip it?

Seeing PHP 7.4 major feature (adding typed properties + preload) most likely CI 4.1 or 4.2 will require for sure min of PHP 7.4 so it will be good if we have at least 1 CI 4 vers with lower requirements.
Best VPS Hosting : Digital Ocean
Reply

#19
(03-13-2019, 08:27 PM)nogueira Wrote: I did a search on the hosts and found that most still use PHP 5.6.40 ....... That's why I can not use Laravel and I probably will not be able to use CodeIgniter 4 ......

luckily, some give you option of choosing what version you intend using
Reply

#20
I agree @sv3tli0, @puschie, the minimum should be 7.2 and recommended is 7.3.
Reply


Digg   Delicious   Reddit   Facebook   Twitter   StumbleUpon  


  Theme © 2014 iAndrew  
Powered By MyBB, © 2002-2019 MyBB Group.