• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
No error message when PHP "intl" extension is not enabled

#1
Hello.

I've spent a lot of my time searching for a "bug".

I am using Windows7 with XAMPP (so Apache 2.x) with PHP 7.4x.

I had a headache while searchig for a (not) bug.

It seems that I had INTL extension disabled in my PHP.
But there is no error/info message about this, nothing.
Access or Error log messages - clean.

It would be nice to have some info while I see "Whooops! .... snag.... try again later" on the screen.

I am using CI4 for the first time. I did not search for dependencies description, but I wanted to load it as fast as I can.
CI_ENVIRONMENT constant did not help (changing to "development").

There are a lot of extensions in PHP. How would I know which one to choose, to remove my problem ?

I wrote it here, just to make sure, that there is another way to find the error about missing loaded extension.
Is there a way ? (skipping testing one by one of course)
Reply

#2
If you edited the env file and added the environment setting CI_ENVIRONMENT = development
you would have seen a message and not a Whooops! message.

Remember once you add the environment to the env file you need to rename it .env
What did you Try? What did you Get? What did you Expect?

Joined CodeIgniter Community 2009.  ( Skype: insitfx )
Reply

#3
(04-06-2021, 03:22 AM)elvisef Wrote: Hello.
I've spent a lot of my time searching for a "bug".
...
I had a headache while searchig for a (not)...
I agree wholeheartedly and still think the Splash Screen should show or at least give informative error messages.

It is unnecessary to fail because of the intl settings not being set or not having writable access to the writable folder. These errors could easily be detected and first time users pointed to the relevant solutions.

The setup is not user friendly and must be off putting to new users
Reply

#4
(04-06-2021, 11:51 AM)InsiteFX Wrote: If you edited the env file and added the environment setting CI_ENVIRONMENT = development
you would have seen a message and not a Whooops! message.

Remember once you add the environment to the env file you need to rename it .env

My bad. I didn't change the name to ".env" - the dot was the culprit.

Alright. But now, what I can see is nothing about "intl" extension.

What I did: I reverted my changes, so I commented the "extension=intl" line in php.ini, just to check if errors are being displayed.

I see information on the screen but unfortunately there is nothing about missing or disabled "intl" extension.

[Image: 7-Gsbsfcn30.png] [Image: firefox-dhdwqer-CPW.png]
Reply

#5
The extension missing throws the red error above. not really to the point.
What did you Try? What did you Get? What did you Expect?

Joined CodeIgniter Community 2009.  ( Skype: insitfx )
Reply

#6
I find it very difficult to associate the Kint error messages with the actual error.

I’m curious to know if Kint was completely disabled what error message would be reported.

I have tried and failed to completely disable Kint but it appears far too embedded.
Reply


Digg   Delicious   Reddit   Facebook   Twitter   StumbleUpon  


  Theme © 2014 iAndrew  
Powered By MyBB, © 2002-2021 MyBB Group.