• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Thumbs creation with Image Library - Problem

#11
[eluser]Soares[/eluser]
All right. So, my localhost is running under a MAC OS X. I'm using MAMP. The webserver runs under some linux distribution (I can't be sure which one).

Jedd, I have no access to the original php.ini file of the server. What I was told to do (by the webserver employee) is to put my own php.ini file in my public_html folder. Well, if I put the MAMP php.ini, it will launch a bunch of errors. For this reason, I made a php.ini file containing only the settings I wanted to be modified. Which is:

Code:
max_execution_time = 200
memory_limit = 500M
upload_max_filesize = 10M
error_reporting  =  E_ALL
display_errors = On

There aren't two files. What the script is doing is: I upload one image and, with this one image, I create two thumbnails. As I said, if I change the order of which thumbnail (mini or big) is created, it is always the *first* that is created.

Xeoncross, I'm indeed using AJAX to do this. I'm using SWFUpload, but I can't see why the problem would be related with this. The debug mode is turned on and, as you saw in the script I posted, if something goes wrong, it will echo the error.

Code:
if ( ! $this->image_lib->resize())
        {
            echo "Erro:".$this->image_lib->display_errors();
        }
        else
        {
            echo "OK";
        }

But nothing appears in the debug window. Only an 'OK'.
display_errors is set to On. And the log isn't reporting any errors:

Code:
DEBUG - 07-09-2009 18:06:22 --> Native_session Class Initialized
DEBUG - 07-09-2009 18:06:22 --> Figuring Out Session ID automagically
DEBUG - 07-09-2009 18:06:22 --> Database Driver Class Initialized
DEBUG - 07-09-2009 18:06:22 --> DX Auth Initialized
DEBUG - 07-09-2009 18:06:22 --> Config file loaded: config/dx_auth.php
DEBUG - 07-09-2009 18:06:22 --> Language file loaded: language/pt-br/dx_auth_lang.php
DEBUG - 07-09-2009 18:06:22 --> Controller Class Initialized
DEBUG - 07-09-2009 18:06:22 --> Session class already loaded. Second attempt ignored.
DEBUG - 07-09-2009 18:06:22 --> Helper loaded: form_helper
DEBUG - 07-09-2009 18:06:22 --> Session class already loaded. Second attempt ignored.
DEBUG - 07-09-2009 18:06:22 --> Model Class Initialized
DEBUG - 07-09-2009 18:06:22 --> Upload Class Initialized
DEBUG - 07-09-2009 18:06:22 --> Image Lib Class Initialized
DEBUG - 07-09-2009 18:06:22 --> [painel_acoes] Classe inicializada

About the php.ini file, what do you guys think about putting the MAMP php.ini and then strip off all the lines the causes errors (which I think is a lot)?


Messages In This Thread
Thumbs creation with Image Library - Problem - by El Forum - 09-07-2009, 10:34 AM
Thumbs creation with Image Library - Problem - by El Forum - 09-07-2009, 11:34 AM
Thumbs creation with Image Library - Problem - by El Forum - 09-07-2009, 12:30 PM
Thumbs creation with Image Library - Problem - by El Forum - 09-07-2009, 01:00 PM
Thumbs creation with Image Library - Problem - by El Forum - 09-07-2009, 01:19 PM
Thumbs creation with Image Library - Problem - by El Forum - 09-07-2009, 01:28 PM
Thumbs creation with Image Library - Problem - by El Forum - 09-07-2009, 02:02 PM
Thumbs creation with Image Library - Problem - by El Forum - 09-07-2009, 02:04 PM
Thumbs creation with Image Library - Problem - by El Forum - 09-07-2009, 02:35 PM
Thumbs creation with Image Library - Problem - by El Forum - 09-07-2009, 02:42 PM
Thumbs creation with Image Library - Problem - by El Forum - 09-07-2009, 03:13 PM
Thumbs creation with Image Library - Problem - by El Forum - 09-07-2009, 03:17 PM
Thumbs creation with Image Library - Problem - by El Forum - 09-07-2009, 05:28 PM

Digg   Delicious   Reddit   Facebook   Twitter   StumbleUpon  


  Theme © 2014 iAndrew  
Powered By MyBB, © 2002-2020 MyBB Group.