• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Codeigniter won't run with APC installed

#1
[eluser]Dennis_gull[/eluser]
I just installed memcache and APC on my localhost and once I ran one of my codeigniter application I got spammed with this message like 200 times over:

Quote:Notice: Constant CI_VERSION already defined in C:\wamp\www\g\mvc\codeigniter\CodeIgniter.php on line 31

I tried to comment out the line but now I have an even bigger problem, the entire server crashes and I get the following error message in my apache_error.log:

Quote:[apc-error] Cannot redeclare class ci_benchmark in C:\wamp\www\g\mvc\codeigniter\Common.php on line 127.

Is there something I have to do to get APC to work correctly?

EDIT:


I solved the problem by turning off apc.cache_by_default, shouldn't I be able to have this on?


Messages In This Thread
Codeigniter won't run with APC installed - by El Forum - 02-28-2010, 09:27 AM
Codeigniter won't run with APC installed - by El Forum - 03-01-2010, 04:22 PM
Codeigniter won't run with APC installed - by El Forum - 03-01-2010, 06:28 PM
Codeigniter won't run with APC installed - by El Forum - 03-01-2010, 09:32 PM
Codeigniter won't run with APC installed - by El Forum - 03-02-2010, 03:42 PM
Codeigniter won't run with APC installed - by El Forum - 03-02-2010, 04:48 PM
Codeigniter won't run with APC installed - by El Forum - 05-08-2010, 01:19 PM
Codeigniter won't run with APC installed - by El Forum - 01-22-2011, 07:03 PM

Digg   Delicious   Reddit   Facebook   Twitter   StumbleUpon  


Users browsing this thread:
1 Guest(s)


  Theme © 2014 iAndrew  
Powered By MyBB, © 2002-2019 MyBB Group.