Welcome Guest, Not a member yet? Register   Sign In
problems with index.php on localhost

I'm having a problem with getting rid of the 'index.php' in CI url's on my localhost. It's working fine on the remote server.

My config file:
$config['base_url']    = "http://localhost/site_admin/";
$config['index_page']  = "";

My .htaccess file:
<IfModule mod_rewrite.c>
    RewriteEngine On

    RewriteBase /site_admin
    RewriteRule ^(.*)$ /index.php/$1 [NC,L,QSA]

    RewriteCond %{REQUEST_URI} ^codeigniter_1.7.2.*
    RewriteRule ^(.*)$ /index.php?/$1 [L]

    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule ^(.*)$ index.php/$1 [L]

Some things to note:

I found this thread and tried all suggestions, to no avail.

I'm using WAMPServer 2.0 on Windows7. It doesn't have the rewrite_module checked by default, however if I enable it then none of my links work anymore. No matter what link I enter, I get the default localhost page.
I know I have to enable rewrite_module to get rid of 'index.php', but for the life of me I can't stop it from rewriting every single link to redirect to the default localhost page.

Thanks in advance

Messages In This Thread
problems with index.php on localhost - by El Forum - 07-26-2010, 02:18 AM

Theme © iAndrew 2016 - Forum software by © MyBB