I am using IS_AJAX but sometimes still get disconnects

#6
[eluser]SPeed_FANat1c[/eluser]
I found a thread

http://ellislab.com/forums/viewthread/170123/

where there is new Session.php file, donwloaded it, replaced the original Session.php
Created table in database. And now userdata is not written. For example:

Code:
function index()
    {
        
        
           $data = array(
                            'username' => 'admin',
                            'is_logged_in' => true
                        );
            $this->session->set_userdata($data);
            echo 'set';    
                  
    }

this code does not add userdata to session. Where could be the problem?

Edit:

I am not an expert but I looked at that Session.php file, function set_userdata. It calls $this->sess_write();

and I see in sess_write() at the beggining there is code

Code:
// Only write if specifically asked
        if ( ! $write )
        {
            return;
        }

So the $write default value is FALSE and it does not do anything. So is this a bug or I just don't understand something?


Messages In This Thread
I am using IS_AJAX but sometimes still get disconnects - by El Forum - 11-16-2010, 08:41 AM
I am using IS_AJAX but sometimes still get disconnects - by El Forum - 11-16-2010, 11:15 AM
I am using IS_AJAX but sometimes still get disconnects - by El Forum - 11-16-2010, 02:36 PM
I am using IS_AJAX but sometimes still get disconnects - by El Forum - 11-16-2010, 02:42 PM
I am using IS_AJAX but sometimes still get disconnects - by El Forum - 11-16-2010, 02:48 PM
I am using IS_AJAX but sometimes still get disconnects - by El Forum - 11-17-2010, 07:11 AM
I am using IS_AJAX but sometimes still get disconnects - by El Forum - 11-19-2010, 02:59 AM

Digg   Delicious   Reddit   Facebook   Twitter   StumbleUpon  


  Theme © 2014 iAndrew  
Powered By MyBB, © 2002-2021 MyBB Group.