• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Arabic not displaying properly

#1
[eluser]shadowcaster[/eluser]
Hi all.

I'm building an English/Arabic website which pulls in data from a mysql database which has the Arabic stored in UTF8 encoding.

I had the good sense to encode the views and controllers in UTF8 before attempting to display the Arabic and here's an example of the output I get using Codeigniter:

114:1 قل اعوذ برب الناس
114:2 ملك الناس
114:3 اله الناس
114:4 من شر الوسواس الخناس
114:5 الذى يوسوس فى صدور الناس
114:6 من الجنه والناس

I've spent many hours trying to fix this but to no avail.

Now I wrote a standalone script to pull the data from the DB just to check it was working correctly and it is:

قل اعوذ برب الناس
ملك الناس
اله الناس
من شر الوسواس الخناس
الذى يوسوس فى صدور الناس
من الجنه والناس

So why doesn't it display properly in CI?

Thanks.


Messages In This Thread
Arabic not displaying properly - by El Forum - 07-21-2011, 06:52 AM
Arabic not displaying properly - by El Forum - 07-22-2011, 02:20 AM
Arabic not displaying properly - by El Forum - 07-22-2011, 05:21 AM
Arabic not displaying properly - by El Forum - 07-22-2011, 06:39 AM
Arabic not displaying properly - by El Forum - 07-22-2011, 08:29 AM
Arabic not displaying properly - by El Forum - 07-23-2011, 07:48 AM
Arabic not displaying properly - by El Forum - 07-23-2011, 11:11 AM
Arabic not displaying properly - by El Forum - 07-28-2011, 02:01 AM
Arabic not displaying properly - by El Forum - 07-28-2011, 03:12 AM

Digg   Delicious   Reddit   Facebook   Twitter   StumbleUpon  


  Theme © 2014 iAndrew  
Powered By MyBB, © 2002-2021 MyBB Group.