Welcome Guest, Not a member yet? Register   Sign In
form_open bug
#1

[eluser]Unknown[/eluser]
well this is my code

Code:
<?php  $attributes = array('id' => "ContactForm");
echo form_open('email/send',$attributes); ?>
<div>
  <div class="wrapper"><span>Nombre*:</span><div class="bg"><div>
  &lt;?php $nombre = array('class'=>'input','name'=>'name','id'=>'name','value'=>'');
echo form_input($nombre);?&gt;</div></div>
  </div>
  <div class="wrapper"><span>E-mail*:</span><div class="bg"><div>
  &lt;?php $correo = array('class'=>'input','name'=>'email','id'=>'email','value'=>'');
       echo form_input($correo);?&gt;</div></div>
  </div>
  <div class="wrapper"><span>Cel / Tel*:</span><div class="bg"><div>
  &lt;?php $telcel = array('class'=>'input','name'=>'tel','id'=>'tel','value'=>'');
echo form_input($telcel);?&gt;</div></div>
  </div>
  <div class="wrapper"><span>Asunto*:</span><div class="bg"><div>
  &lt;?php $subject = array('class'=>'input','name'=>'asunto','id'=>'asunto','value'=>'');
echo form_input($nombre);?&gt;</div></div>
  </div>
  <div class="textarea_box"><span>Mensaje*:</span><div class="bg"><div>
  &lt;?php $texta = array('name'=>'mensaje','id'=>'mensaje','rows'=>'1','cols'=>'1');
echo form_textarea($texta);?&gt;</div></div>
  </div>
  &lt;?php
    echo "&nbsp;&nbsp;&nbsp;";
    $submit = Array ("name"=>"submit","value"=>"Enviar","class"=>"button");
    echo form_submit($submit);
    echo "&nbsp;&nbsp;&nbsp;";
    $reset = Array ("name"=>"reset","value"=>"Limpiar","class"=>"button");
    echo form_reset($reset); ?&gt;
</div>
&lt;?php echo form_close(); ?&gt;
&lt;?php echo validation_errors(); ?&gt;

if i see the view-source:http://localhost/mobiCode/ of the page the form had this link in the action property

Code:
&lt;form action="http://localhost/mobiCode/index.php?email/send" method="post" accept-charset="utf-8" id="ContactForm"&gt;         <div>

and i dont know why put "index.php?email/send" if always in another projects put "index.php/email/send" automatically, does can anyone can explain me where im wrong? thx for your time. Regards!!!


Messages In This Thread
form_open bug - by El Forum - 10-04-2011, 12:50 AM



Theme © iAndrew 2016 - Forum software by © MyBB