Upgrading from old version 1.7.1

#2
[eluser]pickupman[/eluser]
You don't need to incremental upgrades. You can update to any version. The major changes from 2.x going forward is how you extend your controllers/models. Rather extending Controller, you would use CI_Controller. Same goes for models. A few other details in the [url="http://ellislab.com/codeigniter/user-guide/installation/upgrade_200.html"]user guide[/url] for completing the upgrade.

Here's download link for [url="https://github.com/EllisLab/CodeIgniter/archive/2.1.3.zip"]CI 2.1.3[/url].

You will also need to merge /application/config/config.php to add some the additional features that have been added since 1.7.2.

Process looks like:
1. Replace system folder from zip
2. Replace index.php
3. Copy application folder to document root to be on same level as system
4. Merge changes from application/config/config.php
5. Update any other application/config files you may have changed
6. Rename how you extended Controllers and Models


Messages In This Thread
Upgrading from old version 1.7.1 - by El Forum - 12-07-2012, 12:56 PM
Upgrading from old version 1.7.1 - by El Forum - 12-07-2012, 02:04 PM

Digg   Delicious   Reddit   Facebook   Twitter   StumbleUpon  


  Theme © 2014 iAndrew  
Powered By MyBB, © 2002-2020 MyBB Group.