Welcome Guest, Not a member yet? Register   Sign In
Poll: Which PHP version features should CI 4 target?
You do not have permission to vote in this poll.
20 23.26%
11 12.79%
43 50.00%
5.3 (unsuported already)
1 1.16%
This should depend on dev process
11 12.79%
Total 86 vote(s) 100%
* You voted for this item. [Show Results]

Which PHP 5.X version should be considered as Required

IMHO, I think that since the new version would be released at least one year from now (probably more, seen what happended with CodeIgniter 3.0) there is no point on having backwards compatibility code for PHP 5.4. Moreover, and seen that PHP 7 will really benefit many services with its high speeds, I can see how many hosting providers could be upgrading, even if it's only for performance reasons.

On the other hand, PHP 7 has not been released yet, so I think it would be irresponsible not to support previous versions. So, I'm voting for PHP 5.6, but creating the new version thinking on PHP 7, and creating backwards compatibility changes where needed by using phpversion() checks where needed, for example.

So, for me, target PHP 7 and bake it backwards compatible with PHP 5.6.

BTW, for those of you talking about current applications and hosting providers, there is no need for you to update to CI 4.0. The same as you do not have to update to PHP 5.6 or whatever. So you can continue supporting your current applications and hosting providers stuck with CI 1.7 and PHP 5.1 if you feel OK, I think CI 4 should think about the future and about new developments.

Messages In This Thread
RE: Which PHP 5.X version should be considered as Required - by Razican - 04-19-2015, 02:50 PM

Theme © iAndrew 2016 - Forum software by © MyBB