Welcome Guest, Not a member yet? Register   Sign In
Query Builder Protect Identifiers Disable

I am migrating from CI2 to CI3 and previously had this option in my db config:

$db['default']['_protect_identifiers']= FALSE;

When leaving this in, I have a problem with using Session with a database setup. It stops putting quotes around string values apparently.

Error Number: 1054

Unknown column 'f2eced3d7db870757ab1304bf44ceef4c19597c4' in 'where clause'

SELECT data FROM ci_sessions WHERE id = f2eced3d7db870757ab1304bf44ceef4c19597c4

Filename: libraries/Session/drivers/Session_database_driver.php

Line Number: 160

It works fine if I remove that old setting. I have lots of areas that I have used query builder and it is now breaking with identifiers back on. I know that I can kill them off at the method level, but is there a way to turn it off global for the query builder?



Messages In This Thread
Query Builder Protect Identifiers Disable - by zepernick - 07-19-2015, 10:07 AM

Theme © iAndrew 2016 - Forum software by © MyBB