Welcome Guest, Not a member yet? Register   Sign In
Confusing name of view()-method in the tutorial

Dear all,

thank you very much for your posts!

I'm teaching web technologies (like PHP OOP) since a long time and I am web developer as well.

I've realized several projects with CI and I really love this framework. I my opinion, the documentation of CI is ten times better than the one of Symfony and a hundred times better than the one of ZEND Framework.

CI is the best choice to explain basic principles in a PHP-framework like routing, MVC-pattern, form helpers, DB interaction, etc. My intention is to make an outstanding thing even better.

So again: The tutorial is for most of new users/learners the first contact with CI, but:

CI has it's own, native, given names (somehow like keywords) for methods. One of this "keyword" ist "view()".

But in the example, the word "view()" is used for a [controller-method] with I can baptize by myself. It has an influence on the routing

The same word "view()" is in the bottom of the same script (!!!), but there it has completely different meaning (!!!), because here it loads a view.

This fact is poison for a newbie, and I do not want anyone to be confused, because I really love CI. I think there's a real, deep need for changing the tutorials on this point!

Maybe this forum is not the best place for this topic, because it's not me that needs help. I have chosen this forum because of the hint "Not sure where else to ask something?"

Best wishes

Messages In This Thread
RE: Confusing name of view()-method in the tutorial - by sponti - 04-12-2017, 01:31 PM

Theme © iAndrew 2016 - Forum software by © MyBB