Poll: Should CodeIgniter 4 installation require Composer?
Yes
No
[Show Results]
This poll will close on: 12-10-2019
Note: This is a public poll, other users will be able to see what you voted for.
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
CodeIgniter 4 installation shall not require composer

#1
IMHO one of the main thing that makes CodeIgniter attractive to the developer that approaches for the first time an MVC framework, and what makes it different from big frameworks (like Sinfony and Laravel) is the CodeIgniter extremely simple installation process that do not require to install, learn and use another tool like Composer.

I don't know if you still remember when you installed CodeIgniter for the first time, I was in hurry and I didn't have time to waste playing with another tool (Composer), hence I decided to give CodeIgniter 3 a try because it was the only framework comparable (by widespread user base, and online support/tutorials, etc.) to Laravel/Symfony, but CodeIgniter did not require me to waste time learning another tool.

Hence, I think CodeIgniter 4 installation shall not require Composer to be used at all.

What do you think about this?
Reply


Messages In This Thread
CodeIgniter 4 installation shall not require composer - by Balenus - 12-10-2018, 09:14 AM

Digg   Delicious   Reddit   Facebook   Twitter   StumbleUpon  


Users browsing this thread:
1 Guest(s)


  Theme © 2014 iAndrew  
Powered By MyBB, © 2002-2019 MyBB Group.