• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
getting error because of using php 7.2?

#5
I contacted the phpStorm support team. They stated that there is nowhere in phpStorm where I would set this. Here is the error I am getting:

Severity:    Warning
Message:    CI_DB_mysqli_driver::db_connect(): Property access is not allowed yet
Filename:    /opt/docker-substantiator/app/system/database/drivers/mysqli/mysqli_driver.php
Line Number: 201


Backtrace:
File: /opt/docker-substantiator/app/application/core/MY_Loader.php
Line: 277
Function: database

File: /opt/docker-substantiator/app/application/controllers/Users.php
Line: 15
Function: __construct

File: /opt/docker-substantiator/app/index.php
Line: 317
Function: require_once

I get about 7 or 8 of this same exact error, and the  finally I get to this line:
if ($this->_mysqli->real_connect($hostname, $this->username, $this->password, $this->database, $port, $socket, $client_flags))
which has this comment right below it:
// Prior to version 5.7.3, MySQL silently downgrades to an unencrypted connection if SSL setup fails

and this line fails with this error:

Database error: A Database Error Occurred



Unable to connect to your database server using the provided settings.

Filename: controllers/Users.php

Line Number: 15




Process finished with exit code 8
proof that an old dog can learn new tricks
Reply


Messages In This Thread
RE: getting error because of using php 7.2? - by richb201 - 11-08-2019, 06:30 AM

Digg   Delicious   Reddit   Facebook   Twitter   StumbleUpon  


  Theme © 2014 iAndrew  
Powered By MyBB, © 2002-2019 MyBB Group.